Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently did an update on my Ubuntu 11.04. Unfortunately I can't remember what was updated, but I am sure there were some core things.
Anyway, before that update I could change the fan speed, due it's heavy loudness, with an application called nvclock.
When I try to use it now with:
nvclock -f -F 70

I only get following reply:
Segmentation fault

So how can I get it back working, because it's really annoying loud

share|improve this question

1 Answer 1

up vote 1 down vote accepted

With GF6800 on Ubuntu 10.04, i have the same problem. My workaround to change GPU fan speed is:

sudo gedit /etc/X11/xorg.conf

in section "Device" add

Option       "Coolbits" "5"

Restart the PC. Then you can control fan speed with this command:

nvidia-settings -a [gpu:0]/GPUFanControlState=1

and then:

nvidia-settings -a [fan:0]/GPUCurrentFanSpeed=30

where 30 is a number from 1 to 100 % of fan speed.

You can set that two commands in Startup Applications to run at boot, remember it if your GPU overheates.

Cheers

share|improve this answer
    
I recently downgraded my graphics driver, so nvclock worked again. But thanks for that trick. –  Dan Lee Apr 20 '12 at 10:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.