Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I enable the native shortcuts like

  • Alt + Ctrl + T: Terminal
  • Alt + Ctrl + D: Show Desktop

on Gnome 3.

share|improve this question
1  
Note: this is still totally broken on 12.10 and gnome3.4.2. see the reference bugs on the top answer for workarounds. –  gcb Jun 10 '12 at 19:51

1 Answer 1

up vote 20 down vote accepted

GNOME 3.4 uses gsettings for the keyboard shortcuts while Ubuntu still uses gconf for the keyboard shortcuts. Because of this, there is no easy way to enable the native shortcuts for gnome-shell.

If you really want to use them, you need to manually enable them in order for them to work.

For terminal's keyboard shortcut, search for Keyboard in the gnome-shell overview and open it.

Move to Custom Shortcuts and add a new shortcut by clicking on the + button. Add a relevant name to the shortcut. Input gnome-terminal for the command and add the keyboard shortcut you desire.

enter image description here

And, for the other one, you need to have dconf-tools Install dconf-tools installed to enable the shortcut for show-desktop.

Open dconf-editor, navigate to orggnomedesktopwmkeybindingsshow-desktop → Change the value to '<Control><Alt>D'.

enter image description here


If you want other options to use the native shortcuts as well, look for them in the dconf-editor in the sub options mentioned above and modify them accordingly.

References:

share|improve this answer
1  
And, in case if you have any problem adding custom keyboard shortcuts - How to add custom keyboard shortcuts? –  jokerdino Apr 17 '12 at 9:35
    
Launch Terminal is already available under launchers. But it is not working –  Starx Apr 17 '12 at 9:51
    
@Starx You need to create it by yourself. Or else, it won't work. See relevant comment on the bug report. –  jokerdino Apr 17 '12 at 9:53
1  
Ok, terminal worked, now i dont have so many on below the dconf-editor. Do I have to create all that? –  Starx Apr 17 '12 at 9:56
1  
@MariusGedminas if you read the last link on the answer references, there's a few workarounds. it's a pain in the *** (should be gnome3 tagline) but doable. write "<Mod4>t" –  gcb Jun 10 '12 at 19:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.