Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Almost every time I try to add a new software source, I get an error:

james@james-GA-890GPA-UD3H:~$ sudo add-apt-repository ppa:flozz/flozz
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 879E176037576C38DA61862BD2BF771175034BEC
gpg: requesting key 75034BEC from hkp server keyserver.ubuntu.com
?: keyserver.ubuntu.com: Connection timed out
gpgkeys: HTTP fetch error 7: couldn't connect: Connection timed out
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0
james@james-GA-890GPA-UD3H:~$ 

Am I doing something wrong? I'm using cut & paste to avoid typos.

share|improve this question
    
Do you still have an active internet connection when you are trying? Is this for all repositorys or just a few? –  Adam Nov 9 '10 at 10:05
    
Are you behind a proxy/firewall ? –  JanC Nov 9 '10 at 11:28
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure :) –  Ringtail Mar 1 '12 at 17:42
add comment

closed as too localized by jrg Mar 1 '12 at 17:44

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Most probably the port (11371) used for downloading the GPG key from the Ubuntu keyserver is blocked by your ISP/firewall. Unfortunately all the alternate keyservers use the same port.

Hopefully keyserver.ubuntu.com will start using a standard port for this in the future...

share|improve this answer
    
Unfortunately the keyserver sometimes is simply overloaded. –  ddeimeke Nov 9 '10 at 16:32
    
This happens every time I try to add a repository using the method "sudo add-apt-repository ppa:" far as I can determine my Modem/Firewall is not set to block port (11371) and I don't use a proxy –  James Collins Nov 10 '10 at 9:33
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.