Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

x11vnc used to work fine, but in the new 12.04 release I can't get it to work.


16/04/2012 17:22:35 x11vnc version: 0.9.12 lastmod: 2010-09-09  pid: 16524
16/04/2012 17:22:35 XOpenDisplay("") failed.
16/04/2012 17:22:35 Trying again with XAUTHLOCALHOSTNAME=localhost ...
16/04/2012 17:22:35
16/04/2012 17:22:35 *** XOpenDisplay failed. No -display or DISPLAY.
16/04/2012 17:22:35 *** Trying ":0" in 4 seconds.  Press Ctrl-C to abort.
16/04/2012 17:22:35 *** 1 2 3 4
16/04/2012 17:22:39 XOpenDisplay(":0") failed.
16/04/2012 17:22:39 Trying again with XAUTHLOCALHOSTNAME=localhost ...
16/04/2012 17:22:39 XOpenDisplay(":0") failed.
16/04/2012 17:22:39 Trying again with unset XAUTHLOCALHOSTNAME ...

I've already tried various kinds of "-auth" parameters, none worked.

share|improve this question
    
runs fine here. try setting the DISPLAY environment variable to :0.0 or whatever you have running –  hbdgaf Apr 16 '12 at 15:39
    
try xhost + first –  jet Apr 16 '12 at 23:23
add comment

2 Answers

In my case I got it work by using the lightdm auth file:

root@kbrandt-desktop:~# ps wwwwaux | grep auth
root      1815  0.3  1.2  69320 51980 tty7     Ss+  19:11   0:02 /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
root      5870  0.0  0.0   4372   828 pts/0    S+   19:25   0:00 grep auth
root@kbrandt-desktop:~# x11vnc -forever -httpdir /usr/share/vnc-java -noxdamage -httpport 5900 -auth /var/run/lightdm/root/:0 -display :0
share|improve this answer
add comment
up vote 0 down vote accepted

I don't know why, but the display was running on :1 in stead of :0

Executing w in the terminal told me that much

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.