Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I have upgraded my working Lucid PC to Maverick I am unable to log in as a normal user. I can only login as root. If I log in as a normal user the log in screen disappears and reappears with the sound effects. If I type the wrong password then I get authorization failure and back to the log in screen as normal. Even then as root if I try to run some programs it will return to the login screen. The display seems to be fine - it is the onboard S3 - no special drivers.

Please help - I am scared to upgrade my other machines!!

share|improve this question
    
This looks as if some incompatible program from your Lucid installation crashed the X-Server. –  Takkat Nov 9 '10 at 8:26
    
was this a true upgrade, or new install using old home partition? –  Adam Nov 9 '10 at 14:40
    
True upgrade using alternate cd. I used update manager to update everything and then ra the upgrade from the cd. –  HeyPaul Nov 10 '10 at 8:37

1 Answer 1

This could be related to an application or Driver. I have seen Compiz and other programs crash X in the past, so to start with I would start to disable auto run applications.

As you can't get a desktop, start a new session in Failsafe GNOME mode, using the dropdown for sessions, once you have selected your name.

GNOME

Then follow the instructions on this Link to disable your auto start applications.

If you have Compiz enabled, follow this link to see how to disable that too.

Have you tried creating a new user and seeing if the issue affects that account too?

share|improve this answer
    
Thanks for the advice - I will try that shortly. –  HeyPaul Nov 9 '10 at 11:28
    
Yes I did create a new user and that worked until I rebooted the computer. –  HeyPaul Nov 9 '10 at 11:29
    
what did you enable on the user between its creation and the reboot –  Adam Nov 9 '10 at 11:35
    
Ah I forgot - when logged in as root I am unable to add or edit users using users admin tool. The window sit s there doing nothing and all greyed out. I had to use adduser in the terminal. –  HeyPaul Nov 9 '10 at 14:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.