Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi guys from what I see by Googling around it's a common problem but somehow all the threads I've seen end in "Oooo Flash is terrible" and the post dies there.

I'm experiencing a very high CPU usage 100% and more while watching any Flash videos. What I'm running :

  • Latest Flash version available for 64bit in Ubuntu's repositories

  • Ubuntu 11.10 64bits

  • Athlon X2-QL64 on an HP Compaq 615

PLEASE NOTE that I'm experiencing the same issue on a Celeron T3300 with Intel video card

What I tried :

  • Different browser (firefox and chromium behave the same)

  • Disabled the separate plugin-container process and made Flash run in firefox.exe (same behaviour)

  • Changed shell. Gnome3 and Unity behave the same

  • Flash ads blocker (prevents 100% loading just until I actually play the video so it really doesn't make a difference)

  • Open source Flash players. Gnash gives me a very low framerate and a super high CPU usage anyway. Lightspark is unable to play YouTube videos and insta-crashes

  • HTML5 video playback gives THE SAME super high load

If it can help I noticed that xorg usage is low while playing (I saw posts where people seemed to have a very high xorg cpu load but it's not my case)

Any help is really appreciated since I fell in love with Linux and can't stand to see Windows perform way better on the same machine


Update: Turns out after hours that i'm half idiot half forced to do it.

Let me explain

I'm using jupiter to keep the temps under control and using it constantly in power save mode to save about 10°C.

If i use the "ondemand" governor the cpu usage goes down to about 50% while playing (cpu freq doubles in the case of my cpu)

If i set it to "maximum performance" it goes down to about 45% but my cpu goes to about 85C°

So basically the reason is that it's actually using 100% because it needs to and not for strange reasons but i can't afford to cook my battery just to see the cpu usage go down by 50% so i'll just keep it like it is since the playback looks fine even at constant full load. I just hope 12.04 will run cooler

Thanks a lot for the quick answers

share|improve this question
1  
How do you test HTML5? (I have huge lag in 720p with flash and no lag 1080p with html5) –  Alvar Apr 16 '12 at 14:54
add comment

1 Answer

Flash and any video media is cpu intensive. This is why newer graphic cards have hardware media acceleration. You cannot do anything about it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.