Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.10 on my hand-built tower (important specs: Intel Core 2 Duo 3 GHz, 8GB of RAM, NVidia GeForce 8800 GTS with 640 MB of video RAM). It's a bit of a weird setup because I installed Wubi to my hard drive containing Windows XP and then later installed Windows 7 to a different drive, but that's neither here or there.

The last time I booted into Ubuntu, which was probably a few days ago, Unity 3D worked just fine. A little slow, but fine nonetheless. Today I boot up, and Unity doesn't want to work at all. The top bar turned into rainbow glitchiness if I tried to do anything, the dock bar would not do anything, and the whole thing was insanely unresponsive.

I'm not entirely sure what the problem could be. Windows 7 felt the need to run CHKDSK completely out of the blue recently, but since it only scanned C: and Wubi isn't installed at what Windows 7 thinks of as C:, I find it hard to think it's that. (The last time CHKDSK ran on a computer I owned, it was on a Dell laptop trying to fix a defective hard drive, and it caused more damage than it fixed. So I'm suspicious of CHKDSK.) I can't think of any major updates that occured recently that could lead to this.

Thankfully, Unity 2D still works, so I'm not completely locked out. I was using NVidia's proprietary drivers (the one marked "recommended", whichever one that may be), and they worked fine until recently. Any ideas what I could do?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Don't just apt-get remove video drivers. It leads to this situation. What you should do is remove them with additional drivers aka jockey-gtk:
use additional drivers
don't just apt-get remove video drivers Click remove and it will toggle to noveau for you

share|improve this answer

This appears to be a problem with the Apr 11th update to the Nvidia driver. The bug is occurring across distros and is being tracked at Bug #980298. A temporary workaround is to remove it:

sudo apt-get remove nvidia-current nvidia-current-updates
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.