Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought Acer asipre 4250. It have built-in SD card reader. But it is not working. Nothing show in /media or fdisk but something in dmesg.

dmesg:

new high-speed USB device number 3 using ehci_hcd
[  127.396733] scsi5 : usb-storage 2-2:1.0
[  128.526562] scsi 5:0:0:0: Direct-Access     Multiple Card  Reader     1.00 PQ: 0 ANSI: 0
[  128.532512] sd 5:0:0:0: Attached scsi generic sg2 type 0
[  129.008110] ohci_hcd 0000:00:12.0: PCI INT A disabled
[  129.032083] ohci_hcd 0000:00:13.0: PCI INT A disabled
[  129.056411] ohci_hcd 0000:00:16.0: PCI INT A disabled
[  129.338026] sd 5:0:0:0: [sdb] Attached SCSI removable disk
[  129.808328] ohci_hcd 0000:00:14.5: PCI INT C disabled
[  167.728616] usb 2-2: USB disconnect, device number 3
[  169.872284] ehci_hcd 0000:00:13.2: PCI INT B disabled
[  169.872340] ehci_hcd 0000:00:13.2: PME# enabled

fdisk -l:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0006bc6d

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    48828415    24413184    7  HPFS/NTFS/exFAT
/dev/sda2        48828416    50829311     1000448   82  Linux swap / Solaris
/dev/sda3        50829312    99657727    24414208   83  Linux
/dev/sda4        99659774   625141759   262740993    5  Extended
Partition 4 does not start on physical sector boundary.
/dev/sda5        99659776   275439615    87889920    7  HPFS/NTFS/exFAT
/dev/sda6       275441664   451221503    87889920    7  HPFS/NTFS/exFAT
/dev/sda7       451223552   625141759    86959104    7  HPFS/NTFS/exFAT

I found another problem just right now. I format last three drives as EXT4 with disk utility. But they are showing as NTFS/exFAT in fdisk. :-(

share|improve this question

2 Answers 2

Dmesg says nothing while you insert SD card? lspci will (should) show you producer of the reader, which information is needed to resolve your problem.

For setting types of partitions, better use fdisk than GUI tools.

fdisk /dev/sda

press t, choose partition (in your case 5, 6 or 7), 83

repeat for every wrong identified partition. press w at the end.

share|improve this answer

This worked for me.

http://goinggnu.wordpress.com/2009/11/12/read-your-sd-card-with-your-ubuntu-laptop/

  1. Backup the file /etc/modules sudo cp /etc/modules /etc/modules.bak
  2. Add one line to /etc/modules gksu gedit /etc/modules or sudo vi /etc/modules
  3. Tag this on to the end of the file in a new line: tifm_sd

When you restart, you’re card reader will be functional. You’ll see that when you slap an SD card into the reader, it will automount.

But wait, don’t want to have to restart your machine? Go back to the terminal you impatient person and type:

sudo modprobe tifm_sd
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.