Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running 11.10 on a HP/Compaq Presario sr1010z, and the video/audio was working fine with whatever was in the machine already. Then I installed a new video card (PCI/nVidia), which disabled the audio/video on the old one automatically. But that card didn't work out too well so I removed it.

Now the video is back to normal, but the audio is gone.

I have tried the following:

  1. In BIOS, set audio to on/enable rather than Auto
  2. Looked for hardware in System Settings > Sound, but nothing shows up there
  3. But when I run the sysinfo utility, I get the description of the audio controller

When I do a sudo aplay -l, I get:

aplay: device_list:240: no soundcards found...

And then when I do a lspci -v | grep -A7 -i "audio", I get the following:

00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] SiS7012 AC'97 Sound Controller (rev a0)
    Subsystem: Hewlett-Packard Company Device 2a05
    Flags: bus master, medium devsel, latency 32, IRQ 5
    I/O ports at a000 [size=256]
    I/O ports at a400 [size=128]
    Capabilities: <access denied>

00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f) (prog-if 10 [OHCI])

Any ideas on how to fix this?

Thanks

share|improve this question
add comment

1 Answer

I ran the Ubuntu CD to repair installation and that fixed the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.