Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Mac OS X 10.7 "Lion" and Ubuntu 11.10 on my MacBook Pro using these instructions: Creating a shared home partition between Linux and Mac OS X.

After changing the location of my home folder to the new location, it gives me the error in the title, and my username no longer appears in the login screen. Using the "Other" option with my username seems to make it try to log in, but the screen quickly flashes between blank and a shell before kicking me back to the login screen without notice.

I'm trying to share my home folder between Mac OS X and Ubuntu, using an hfsplus partition (unjournaled) between the two. The home partition seems to mount fine as /home, and I am able to modify it under Ubuntu.

Below is the line I've added to fstab:

/dev/sda3 /home hfsplus defaults 0 1

I should also note that I changed my account's username and home directory location to match this, though I've double checked that and everything seems in order there...

Thank you in advance for any assistance.

Edit: It seems that the /etc/passwd file didn't have my new home directory's location in it, so I changed that, and I am now able to log into my account, although I am still not listed in the login screen, and my username in the menu on the top right shows up as "[Invalid UTF-8]"...

share|improve this question
up vote 1 down vote accepted

The last column in the /etc/fstab line you've added is fsck options. "1" means the order in which fsck should check the partition.

You probably don't want to check that filesystem from Linux - try changing the line to

/dev/sda3 /home hfsplus defaults 0 0

and see if it helps.

share|improve this answer
Awesome, that seems to have fixed that part of the issue. My account still doesn't show up in the login screen, though. I found that in the passwd- file my home folder location was incorrect, and I modified that, and I am now able to log in, though I'm not listed on the login screen.. – Arctic Shadow Apr 15 '12 at 21:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.