Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the title says I can't enable the Unity 3D support when I'm using open-source drivers (xorg-edgers). I have an xfx Radeon HD 6950 by the way.

If I install the proprietary 12.3 drivers from AMD it works, but I get poorer 2D performance than the open-source drivers and also I get some freezes and lock ups at random. So because of this I'm trying the open-source drivers and so far no issues at all, except this one.

Running this command $ /usr/lib/nux/unity_support_test -p shows this:

OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string:  2.1 Mesa 8.0.2

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

And this command $ lspci -nn | grep VGA shows:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Cayman PRO [Radeon HD 6950] [1002:6719]

So, is this normal? Do I need to go back to proprietary drivers to enable Unity 3D?

If anyone can give me help, I'll much appreciate it.

share|improve this question
    
I have the same result with Intel Corporation Mobile 945GSE Express Integrated Graphics Controller [8086:27ae] (rev 03) –  int_ua May 2 '12 at 17:42
    
FYI: sudo apt-get install xserver-xorg-video-intel fixed my problem. –  int_ua May 2 '12 at 18:20
add comment

1 Answer

I was having same problem with an integrated Radeon 4250 (RS880) and solved it after installing also the xserver-xorg-video-ati package.

I read in the info about the package that:

"Users of Rage, Mach, or Radeon boards may remove this package only if they use Driver "r128", "mach64", or "radeon" in /etc/X11/xorg.conf instead of relying on autodetection."

So it seems I was using autodetection.

Now I get 3D acceleration (and Unity 3D) although I noticed the mouse cursor is not smooth at the login screen (it freezes for a fraction of a second each one second).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.