Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a DSL connection in Ubuntu 11.04 and am having problems loading content from certain websites(such as, mostly providing CDN services, though google and gmail run perfectly.

I have tried every suggestion asked at problem loading internet pages as I have the same problem. Also tried to remove the DNS Cache and Browser Cache.

I have tried using Google DNS Server: and, but nothing seems to work. Though when I browse the websites in Windows XP then it does not pose any problem.

This problem has come up only few days ago and has affected every browser(Chrome, Firefox and Opera) in Ubuntu 11.04.

Thanks in advance.

share|improve this question
I have even updated my Chrome to the latest stable version. – Cody Apr 15 '12 at 17:13
Can you comment on which websites you have this problem with? – Luis Alvarado Apr 15 '12 at 17:16, other websites loading content from, and almost every CDN service.. – Cody Apr 15 '12 at 17:21
Though I get the following response from on command line 64 bytes from ( icmp_req=1 ttl=50 time=313 ms – Cody Apr 15 '12 at 17:25
Can you elaborate on 'having problems loading content'? Maybe upload a screendump of what you see? – jippie Apr 15 '12 at 17:26

I suffered this exact same fate, and also couldn't find anything on how to fix it. I did finally get it to work, and wrote a blog post titled Facebook, Youtube, LinkedIn and other CSS and JavaScript files from CDNs not loading on Ubuntu that explains the process I went through and things I tried.

In short, the solution was to create a manual connection to the router (i.e. not Automatic DHCP), with a custom DNS server. This is done by right-clicking on the connections icon -> Edit connections... -> Edit -> IP4 Settings. I used as Primary DNS, but it could be anything other than the IP of the router, that is the default. The important thing here is that I'm circumventing the router when it comes to DNS traffic, as opposed to simply setting a different DNS server on the router itself.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.