Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I hit a brightness key on my laptop's keyboard, it adjusts the brightness by three steps instead of one. How can I fix it so that it only adjusts one step at a time?

I am using an Acer Aspire D250 with the newest firmware. It was working better when I was using Ubuntu 10.10 with older firmware (although the scale was off).

Any tips on debugging this would be appreciated.

Edit: My graphics:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

/sys/class/backlight$ ls
acpi_video0  intel_backlight
share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

I had a smiliar problem:

I run Ubuntu 12.04 on my netbook (Acer Aspire One D255E) and I have the following problem with the brightness settings: If I want to adjust the brightness with the fn-key, I can only change between three brightness steps, but my netbook has nine brightness steps.

Ruben Bakker gave this instructions, which solved the problem.

Easy fix. In the terminal:

gksudo gedit /etc/default/grub

You will find this line in the new opened window:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Save and close the window and type this in the terminal:

sudo update-grub

Then reboot. Rejoice :)

Link: Problem with brightness settings with Acer Aspire One D255E in 12.04

share|improve this answer
    
That did the trick! Thanks! –  erjiang Aug 14 '12 at 16:54
    
I tried that but it didn't work. Worse still, my screen stayed black after wakeup. –  To Do Nov 18 '12 at 14:11
add comment

Put 'blacklist video' (without the quotes) in

/etc/modprobe.d/blacklist.conf

and reboot. Hopefully this should solve your problem.

share|improve this answer
    
No, blacklisting video didn't do anything, unfortunately. –  erjiang Apr 17 '12 at 14:28
add comment
# rmmod video
# modprobe video brightness_switch_enabled=0
share|improve this answer
1  
What is this for? The answer is incomplete. Please post all the steps, start to finish, so new users can understand. –  Tom Brossman Oct 31 '12 at 12:39
    
@RickGreen-Turbo This canned comment is never appropriate when posted in response to an answer. The linked meta question is not saying to avoid posting incomplete answers as answers (and it is even sometimes appropriate to do so). It's saying to avoid posting them as comments. –  Eliah Kagan Jan 3 '13 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.