Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Why is it that my system dies when multitasking(it is happening from 11.10) on Ubuntu11.10(Unity), Kubuntu 11.10(KDE) and Deepin Linux which is based on 11.10(Gnome-Shell) The thing is that I thought with 12.04 I would get performance like I used to get on 11.04 on which everything used to run fine without any lag or hiccups.

The same lagging(Browser starts to stutter, increased delay in the launching of dash and applications)is happening on 12.04 http://i.imgur.com/YChKB.png and http://i.imgur.com/uyXLA.png . I believe that my system configuration is sufficient for running Ubuntu as you can check here http://paste.ubuntu.com/929734/ .

I had the Google voice and chat plugin installed on 12.04 so someone suggested that I should remove that and see if the performance improves but no such respite(I am having this on multiple operating system based on Ubuntu 11.10 as I have mentioned above). On a friends suggestion Ran Memory Test through Partition Magic and my system passed that fine.

One thing more that I would like to know is that why when I have 2Gb Ram and 2.1GB swap does my system starts lag and run poorly when Ram consumption goes 500+. If you require anymore information I will gladly provide it.

share|improve this question
    
I would add that you don't need the gtalk plugin if you use the built in empathy chat client. It supports audio/video afaik. –  hbdgaf Apr 14 '12 at 19:09
    
That plugin is required for g+ hangouts. I use empathy for my all other instant messaging purpose. –  Mohammad Kamil Nadeem Apr 14 '12 at 19:35
    
Probably you have too many apps on startup. Can you try if the issue happens on a clean install too? –  Bilal Akhtar Apr 14 '12 at 22:57
    
@Bilal Brother I don't have too many apps on startup. I have done clean install of Ubuntu 11.10, Kubuntu 11.10 and Deepin Linux and this problem has persisted. I installed 12.04 Beta 1 and then have updated it to the get to Beta 2. –  Mohammad Kamil Nadeem Apr 15 '12 at 3:12
1  
saw something intresting on the currentdmesg.text you put up, "486136] CPU0: Core temperature above threshold, cpu clock throttled (total events = 1) [ 89." hmmm. –  Mateo Apr 15 '12 at 20:05
show 1 more comment

2 Answers

up vote 5 down vote accepted

You have used 3 different versions of 11.10 and now you move to 12.04 with the same result. This may be telling you something. I don't know of all the variables here and don't intend to diagnose your hardware issues.

I would suggest however, that if your computer's performance level was satisfactory using 11.04 move back to it. Not all hardware and configurations are the same on each and every computer therefore not every computer will react the same to the installed OS.

This link about about system configurations and how to improve performance should help.

share|improve this answer
    
Thank you for replying although it seems you hurried it. First of all when you haven't looked at thesystem specs then your reply is pointless. 2.4Ghz core 2 duo and 2gb ram is well above the minimum requirement. Add in a nvidia 9800Gt to that. Suggesting using 11.04 makes no sense. Also use words carefully as you made a grave mistake by using blame. I am asking why is it not running well and not saying that it must run well on my machine, I love Ubuntuso if it is established that the,problem is in my hardware, I will gladly switch to xubuntu or some other lighter option. –  Mohammad Kamil Nadeem Apr 14 '12 at 19:30
    
@Matthew Xubuntu is in my mind also. The quad core and triple the Ram is not an option for me. –  Mohammad Kamil Nadeem Apr 15 '12 at 3:40
    
Thanks @Matthew,the link provided with you also supports that my system should run fine with Ubuntu(Unity 3D) 12.04. Have filed a bug bugs.launchpad.net/ubuntu/+source/unity/+bug/982488 as per a brothers suggestion on launchpad. –  Mohammad Kamil Nadeem Apr 15 '12 at 18:17
    
I have installed Xubuntu-Desktop on my existing Ubuntu Install and it running fine youtube.com/… . Will do a fresh installation of Ubuntu 12.04 when it releases and see how that works out. Thanks for helping guys. –  Mohammad Kamil Nadeem Apr 21 '12 at 2:47
add comment

First of all I am sorry, extremely Sorry for not checking up on my hardware and pinning the problem on Ubuntu :'(. The problem was related to CPU overheating and Thanks to Matthew for mentioning it. I was discussing the system performance problem that I was facing while I was on Crunchbang to see whether an older Kernel and Openbox does the trick and then I showed this askubuntu post to my friend Chris and he suggested the problem was with overheating of CPU. Got my self a good thermal paste, applied it, installed Ubuntu 12.04 but I was still doing 86 Degree Celsius+ http://paste.ubuntu.com/951603/ as before but then today I checked the Heat Sink and it had 2 of its screws loose as they had gone a little off by the side. So I made some space in my cabinet then pushed them in with the help of a screwdriver and now here is the result http://paste.ubuntu.com/951803/ 63 degree Celsius and here http://i.imgur.com/28lYE.png you can see I am multitasking my system greatly and the system is like a breeze. Thanks Once again everyone for helping me out.
Thanks to FOSSfreadom also who spotted that it was a hardware issue. Sorry for my imprudence.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.