Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i tried to install bricscad from the deb file but is for 32bit systems.So i had problems and i downloaded the .tgz file and ran tar -xvf and i was in the directory /opt/bricsys/bricscad/v12 So i managed to run bricscad with the command sudo sh in the directory this.So my question is, do you have any idea of how to make a launcher or smthing so i can run the program from an easier way?I cannot find it in dash(unity) or in the desktop.

Any help will be great! Thanks

share|improve this question
up vote 0 down vote accepted

Yes, you can create the launcher you need. Fist of all, my Ubuntu is in Spanish, so I will translate some words; I hope you understand me.

1.- Create a proper script that run the Bricscad script.

Open gedit and write this:

cd <path_to_Bricscad_script>

Save the file into your personal folder (/home/your_user_name) with the name (the fist dot hides the file, only if you want to hide it).

2.- Create the launcher.

For Unity: Press the Super key (that one it usually has the MS Windows logo) and write Main Menu (this is my translation from spanish). So, you will find a program to create launchers. Select a menu, for example Graphics, and then click on the New Item button. Select an aplication type, choose a name, an icon, a comment, and for the command option write sh

3.- Create a Unity launcher (optional).

If you want an icon on the Unity launcher, look for your app using the dash, and then drag it and drop it over the Unity laucher.


share|improve this answer
Thank you very much!Your help gave me a very nice information about scripting because i am learning about python now on!So, i want to ask you something more.I installed google sketchup with playonlinux.The launcher is ready automatically from playonlinux but when i double click that it does nothing. In the properties i found the command it uses-->/usr/share/playonlinux/playonlinux --run "Google SketchUp" – gabriel Apr 14 '12 at 19:30
Any other very usefull idea for me?thanks – gabriel Apr 14 '12 at 19:30
I am trying to learn Python too! About your problem... what happen if you run that command on a terminal? Nothing too? – lesco Apr 15 '12 at 5:34
well, when i run it from terminal does nothing!It gives me the same error as i run playonlinux from terminal. Here is the message – gabriel Apr 15 '12 at 7:17
Traceback (most recent call last): File "", line 25, in <module> import wx ImportError: No module named wx – gabriel Apr 15 '12 at 7:17

In Kubuntu / KDE I can simply right click on the [K] (start) button and then choose "Edit applications". A small application window appears that lets you define new entries in the menu. I bet for Ubuntu there is a simalar way of adding launchers.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.