Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I select "connect to the hidden wireless Network" from the gnome wireless Menu and select the preconfigured template, I get always an authorization box when logged in as normal user.

How can I make that normal users don't have to authenticate for connecting to a hidden wireless?

share|improve this question

1 Answer 1

Edit/or create the Policy Kit definition file that (may or may not be included with your installation

sudo nano /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

Insert or Find the following chunk

[Adding or changing system-wide NetworkManager connections]
Identity=unix-group:admin
Action=org.freedesktop.NetworkManager.settings.modify.system
ResultActive=yes

Change

Identity=unix-group:admin

To read

Identity=unix-group:network-users

Create the group network-users

sudo addgroup network-users

Add yourself (repeat for other users, replacing $USER with their username)

sudo adduser $USER network-users

You may not have to restart for this to take effect.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.