Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Laptop knows an access point of my uncle's place. He is using a standard one given by the ISP, e.g. FRITZ!Box 6360 Cable. Alas, at my home there is also an access point with the same SSID. Ubuntu tries to connect to it, which of course is futile.

Is there a way to make Ubuntu understand which SSID it is supposed to be connecting to?

share|improve this question
up vote 1 down vote accepted

Wireless networks may have the same SSID, but they should not have the same BSSID, so edit the wireless connection and provide the BSSID for the network you do want to autoconnect to.

Run the following command in a terminal. It will list the SSID and BSSID of all wireless networks in range.

nmcli -f ssid,bssid dev wifi

Click on the network manager icon in the top panel -> Edit Connections -> Wireless tab -> select the saved connection by its SSID and click Edit. Fill in the BSSID and click Save. Now it should only autoconnect if both the SSID and BSSID match.

share|improve this answer

Easiest way to do this is the change your SSID so it doesn't interfere.

Now, I don't know what your router's config looks like, but it should be fairly simple to do.

share|improve this answer
That's why I clarified that's my uncle's access point. He won't reconfigure all his devices for my remote convenience :) – k0pernikus Apr 14 '12 at 15:06

I had the same situation and the solution I came up with was to disable auto-connecting to this wireless network.

That is:

  1. Click on network manager icon in the top panel.

  2. Select "Edit Connections".

  3. Go to the "Wireless" tab.

  4. Select the network by it's SSID to configure settings.

What I did was uncheck the "Connect automatically" check-box, and it stopped connecting to the wrong network.

The drawback is that when the correct network is accessible, you have to connect to it manually.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.