Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu, my internet speeds (which would normally be good) is very crappy and I can't find help anywhere. Please help! I have an HP Pavilion g7 1310-us and the type of wireless receiver I have is a Broadcom 802.11 a/b/g/n.

share|improve this question
add comment

1 Answer

got this thing solved for me (well, I didn't myself, got the solution here) in a terminal, write:

echo "options iwlagn 11n_disable=1" | sudo tee /etc/modprobe.d/iwlagn.conf
sudo modprobe -rfv iwlagn
sudo modprobe iwlagn

hope this helps.

Edit

try the following commands

sudo ifconfig wlan0 down
sudo rmmod -f iwlagn
sudo modprobe iwlagn 11n_disable=1
sudo ifconfig wlan0 up

Try browsing again and if there is an improvement, make this change permanent by
loading this kernel module at boot with the 11n_disable option enabled. This would be done by modifying your /etc/modules file by the following:

echo "iwlagn 11_ndisable=1" | sudo tee -a /etc/modules

If that does not work then-

create an 'options' file:

gksu gedit /etc/modprobe.d/options.conf
and add the line

options iwlagn 11n_disable=1

Hope this will help.

share|improve this answer
    
When I put the first line in I got:" tee: etc/modprobe.d/iwlagn.conf: No such file or directory" –  Excalisnake Apr 14 '12 at 14:07
    
edited my ans. see if it works for you –  Ashu Apr 17 '12 at 5:47
    
Anyway I added "wl" in /etc/initram-fs/modules and executed update-initramfs -u. Seems that fixed the issue –  user55370 Apr 17 '12 at 18:50
    
so my soln didnt work for you? –  Ashu Apr 18 '12 at 4:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.