Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

What I am trying to do couldn't be more logical I think. I have a 40gb drive with two partitions, Xp and Ubuntu. I have dual boot, everything boots and works perfectly. I have about 9gb free in the Windows partition

When I run Gparted I only see 40gb unallocated space, booting from Gparted Live CD. What the hell is going on ? I've read everywhere this is a common problem, however it has no sense something like this remains unsolved by gparted developers, considering what I am trying to do is the very basic step anybody wanting to migrate from Windows to Linux would od

Something like this honestly doesn't give anything else than frustration Could anybody on this forum be so kind to explain whats' going on ? Thanks

share|improve this question

closed as too localized by Ringtail, fossfreedom Jan 13 '13 at 11:01

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Actually what are you going to do?, delete XP partition? use Disk utility instead of gparted and scan drives. is it the same? –  Prasad RD Apr 14 '12 at 4:09
mayby GNOMEparted (Gparted) not for the UNITY interface? –  user108625 Nov 16 '12 at 19:35
This question appears to be abandoned. Unaccepted answer or unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Flagged for deletion. Thanks! –  Ringtail Jan 13 '13 at 3:26

1 Answer 1

Your partition table is probably bad. DO NOT write a new partition table or you will wipe out your hard drive!

The solution is repairing it. You can first try using testdisk and rewriting it, if it doesn't work you can use

fdisk -l

To check for problems on your hard drive.

For more information, see

man fdisk

OR you can look at this forum post.

share|improve this answer
Thanks for your replies. Prasad: I am basically trying to allocate some of those 9gb into the linux partition, basically resizing Linux partition to take advantage of the free space. The problem at this point is not that, but that I can't even see anything in Gparted. sudo fdisk -lu shows everything correct to me . What testdisk basically does ? –  Diego Apr 14 '12 at 4:16
@Diego Test disk is a utility to help recover lost partitions and/or make non-booting disks bootable again. You can find more info about Test disk at –  Ravi Apr 14 '12 at 4:25
Just to be clear: you didn't install Ubuntu inside Windows, that is through WUBI, did you? –  Kelley Apr 14 '12 at 4:27
Of course not, I installed Ubuntu from the CD. In fact, during Ubuntu 11.10 installation I was perfectly able to go through the setup to separate about 5gb from the windows partition (I had only one NTFS partition at that time) in order to install Ubuntu .Everything just ran fine. The problem is just now, running GParted –  Diego Apr 14 '12 at 4:34
@Diego Your partition table is somehow corrupted, that's why Gparted is displaying your partitions as unallocated space.... –  Ravi Apr 14 '12 at 4:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.