Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a clean install of Precise with Gnome fall-back desktop on an Acer Aspire lappie. The mic won't work on Skype unless I switch off 'autospawn' in pulseaudio. That solution kills all audio controls for the system (but the mic works in Skype).

Would be nice to simply fix the mic in Skype and not mess up the GUI controls for the system. Does anybody have a solution for this?

share|improve this question
    
screw the pulseaudio... this is the solution: askubuntu.com/questions/157931/… –  user180802 Aug 2 '13 at 17:12
    
screw the pulseaudio... the solution is askubuntu.com/questions/157931/… –  user180802 Aug 2 '13 at 17:13
    
Pulse audio works fine, it was a hardware problem, I have posted my solution further down the page. –  oneandy Aug 4 '13 at 7:11

3 Answers 3

Not sure how to get to the "multimedia > phonon > audio recording" setting mentioned above; but I managed to sort out my own particular issue as follows (and this might not be 100% related to the OPs issue, but there seem to be many people looking for such help)

I noticed that Skype was using my webcam mic, which is built into my monitor and too far away to be useful. I wanted it to use my headphone mic. It seemed hard to convince it to change. Eventualy, I ran pavucontrol, started a test call in Skype, which brought Skype onto the "recording" tab, and here I could see it was recording from the monitor webcam device. So I chose the internal audio device (basically, my sound card), and all was working well (if a little too loud, but that's easily solved, you never heard anyone complain their mic is too loud in skype!)

No idea why it's so hard to point an application at a different device, or maybe it's skype's fault for not using some sort of 'default' (though I don't see any concept of a default input device in pavucontrol)

HTH

share|improve this answer

Had the same problem. solved it by going to the system setting > multimedia > phonon > audio recording > selected my webcam microphone and clicked prefer until webcam microphone was on the top for all settings in the audio recording section. I then did an echo test call in skype and everything worked.

share|improve this answer

I solved this problem after months and months of not being able to get it working properly. I discovered that this laptop has "stereo, or mono" input via the built in microphone (sorry, can't remember which, but the solution was to open pavucontrol, split the channels on the input (microphone) and reduce the volume of one of the to zero. Works perfectly, haven't had a problem since. I now use Alsa and Pulse, all normal.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.