Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed ubuntu 11.10 and when on firefox i can get onto google or google earth and even gmail.But it wont connect to amazon or ebay or bbc or itv homepage.It only seems to like google I have ethernet connection.I also cant download from download centre Yet downloaded google chrome no probs. Weird

share|improve this question
    
what happens when you ping? By this I mean, type at the terminal: ping -c5 amazon.com where you can replace amazon.com by any other website. You should get a response back from Amazon and everywhere else. If you don't, then it's a general Internet connecitivy issue, not a Firefox issue. –  Chan-Ho Suh Apr 13 '12 at 22:07
    
ok I ping amazon and ebay .I got back 5 packets transmitted,0 received,100% packet loss –  David Kelly Apr 13 '12 at 22:23
    
does this mean anything to you ? –  David Kelly Apr 13 '12 at 22:23
    
Yes. ping has nothing to do with Firefox, so this means the issue is with your general Internet setup. I would guess your DHCP is not configured correctly. You're connected directly by ethernet, not through a router, right? What's your ip? –  Chan-Ho Suh Apr 13 '12 at 23:04
    
Oh, and try the ping with google.com. From what you said, you should get packets received back, but let's make sure. –  Chan-Ho Suh Apr 13 '12 at 23:05
show 10 more comments

3 Answers

It sounds like you need to call your ISP.

share|improve this answer
add comment

Try to set the DNS servers to 8.8.8.8 and 8.8.4.4 which are open google servers. Because I think that there is something messed up at your ISP, and that is why google chrome works, because it uses these by default.

This can be set in network manager, in the upper right corner.

UPDATE: Not exactly in the corner, but a little left.

You can also edit the /etc/resolv.conf file with sudo gedit /etc/resolv.conf and add the nameserver 8.8.8.8 line.

share|improve this answer
    
Sorry but all I have in upper right corner is system settings,displays,etc I cant download anything from ubuntu software centre either.But I can connect to youtube and googleI. –  David Kelly Apr 13 '12 at 21:43
    
Sorry, I meant the network indicator, and it is not in the corner, but a little left. OR also you can open the system settings and select the network. Here you select the settings which will open a new window. Select your connection and click edit, then switch to the IPV4 tab, where you can change the settings. I will also add the command line method. –  gajdipajti Apr 13 '12 at 21:58
    
Ok I went into network.nowhere does it say settings.It tells me I am WIRED and connected through auto ethernet then gives speed ip address etc.I know i am connected to internet just cant get anything other than google .Sorry But thanks for your advice . –  David Kelly Apr 13 '12 at 22:04
    
Then do open a terminal and write sudo gedit /etc/resolv.conf and add nameserver 8.8.8.8 there in a new line. And save, and exit. –  gajdipajti Apr 13 '12 at 22:07
    
ok... done that the nameserver i have there is 194.168.4.100 when I put in 8.8.8.8 line came up "attempting to set the permissions of /root/.local but failed.no such file or directory –  David Kelly Apr 13 '12 at 22:11
show 4 more comments

I once had that especially images from CDNs were not loading.

The solution for me was setting the DNS setting to 192.168.1.3. (I don't know why exactly .1.3)

You can do this by go

Network Connections → Edit a connection → IPv4 Settings → DNS Server

share|improve this answer
    
Also try ping amazon.com in the terminal. First response should be PING amazon.com (72.21.194.1) 56(84) bytes of data., with the IP address. –  arian Apr 14 '12 at 0:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.