Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I downloaded spark_2_6_3.tar.gz from http://www.igniterealtime.org/downloads/index.jsp.

After extracting the file and cding into Spark, I ran both ./starter and ./Spark but the messenger client is not running. I am using Ubuntu 11.10, 64 bit.

share|improve this question
    
have you got java installed? If so - is this openjre or oracle jre? which version? –  fossfreedom Apr 13 '12 at 22:24

1 Answer 1

One of a few things might be wrong:

  1. Your script your trying to run isn't executable
  2. You version of Java is not quite right for the Spark client:

    sudo apt-get install galternatives

    sudo add-apt-repository ppa:ferramroberto/java

    sudo apt-get update

    sudo apt-get install sun-java6-jdk sun-java6-plugin

    (then use Gnome galternatives GUI to set the default)

  3. Something else...

share|improve this answer
1  
sun-java6 does not exist in the repositories since 11.10. This is because Oracle's licensing on Java is incompatible with Ubuntu's packaging license requirements. Refer to help.ubuntu.com/community/Java for information about how to install Oracle java –  Thomas W. Apr 13 '12 at 23:04
    
It requires Sun java to work, java 1.6 is apparently supported and works for me –  tomodachi Nov 12 '12 at 22:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.