Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Sound works fine from the internal speakers from my iMac 2011, but the headphone and microphone jack seem to have no output/input. Any ideas on how to fix this?

share|improve this question

Open up a terminal and enter alsamixer. Navigate with the left and right arrows, unmute by pressing m and change the volume by using up or down.

Out of all of the solutions I have tried this is the only one that worked on my Intel® Core™2 CPU T7600 @ 2.33GHz × 2 Macbook Pro. And it is so easy to do!

share|improve this answer

I've been trying to get my headphone jack to work on my iMac. Nothing worked except upgrade the kernel to the 3.7.2 version.

As soon as I did that, all sound issues went away.

Update: My apologies as I'm new to posting anything here. I followed the instructions on upubuntu:

Then, I recently upgraded to 3.7.3 and all sound works just fine:

Hope this helps.


share|improve this answer
It would be nice if you edit your answer and upload information about How did you upgrade the kernel. – Lucio Jan 20 '13 at 19:23
Please avoid posting the same answer in more than one place. When tempted to do so, this usually means that either: (1) the answer should be customized to account for what is different about the different questions, or (2) one question should be flagged for closure as a duplicate of another question. (You can flag posts once you gain 15 reputation on the site.) – Eliah Kagan Jan 20 '13 at 23:53

Did you check the mixer settings after you connect the earphones? Mine (although I'm still on 11.10), whenever I plugged in the earphones, the volume gets muted automatically.

If the mixer settings are fine in your gui, open up a terminal and check alsamixer. Navigate with the left and right arrows, unmute by pressing m and change the volume by using up or down. esc will exit.

share|improve this answer

I had the same issue and the alsamixer option only works until you unplug the headphones. then it goes back to muted. The 3.7.3 kernal resolved the issue for me. Thanks for the tip!!!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.