Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried adding rfkill block bluetooth to /etc/rc.local. This did not work.

I tried adding both blacklist bluetooth and blacklist btusb to etc/modprobe.d/blacklist.conf. This did not work.

So I went to Synaptic to remove it altogether, but when I marked bluez for removal it said it was going to also remove gnome-shell as well! So naturally I didn't do that.

(Is it sane to run a potential security problem like bluetooth by default? And why is something like that so tightly integrated into Gnome shell?)

Can anyone tell me how to get rid of this annoying and unnecessary process?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Have you tried cd /etc/xdg/autostart && sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' bluetooth-applet.desktop && sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' bluetooth-applet-unity.desktop then going in to startup applications and unchecking the box? reference here.

Adding the rfkill stuff, should cause any bluetooth devices to not associate. So your "security problem" is solved.

The applet Is just an indicator. The Network-Manager applet still starts if it's not managing any interfaces.

The steps above will let you turn off the applet though.

share|improve this answer
    
Excellent advice! That worked, thank you. –  dunderhead Apr 13 '12 at 11:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.