Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This morning, I logged into Unity 3D and noticed that everything was really slow and unresponsive. I pressesd ctrl + alt+ F1 to open a terminal and diagnose the problem. It turns out that compiz is constantly using 100% CPU.

I checked the software center for recently installed updates and found out that yesterday some updates for the nvidia driver had been installed. I have installed the nvidia driver from the System Settings -> Additional Drivers menu. I'm using Ubuntu 11.10 64 bit and my videocard is a Nvidia 8800GTS.

I have tried the following to solve the problem:

  • Uninstall and reinstall the current driver (I have the 'version current [recommended]' installed)
  • Install another driver version. In the Additional Drivers menu some other driver are available
  • Install the nvidia driver from a PPA

I was unable to solve the problem. Any ideas?

share|improve this question
    
This compiz drives me crazy! I want to avoid it but couldn't as same as I want to avoid flash! :p –  Ravi Apr 16 '12 at 16:42

2 Answers 2

Same problem here. The desktop freezes after a login into Unity desktop environnement.

The solution was to force the previous nvidia-current driver.

  1. Log in with the desktop environnement 'ubuntu safe mode' (without compiz)
  2. deactivate the PPA for the nvidia drivers (Perhaps it is possible to also use the previous ppa driver, but its not tested)
  3. Force 'nvidia-current' Version 270.41.06-0ubuntu1 instead of 270.41.06-0ubuntu1.1
  4. After the deupate process completed do a reboot

I hope it solves your problem too.

Greetz Adreamus

share|improve this answer

Download driver from Nvidia Website

While on desktop hold [ctrl + alt + F1]

log in

Go to download directory [cd /home/usernamer/folder] case-sensitive* Type [sudo service lightdm stop] to terminate Xserver Type [ls] to view whats in the current directory

Type the file name as seen in the directory in the following manner case-sensitive* [sudo sh ./NVIDIA-Linux-x86-295.40.run]

After accepting terms and conditions you with be asked to setup xConfig just choose [yes] to auto config unless you want to customize your config settings. After that you should be back at terminal

type [sudo service lightdm start] to initiate Xserver which should bring you back to the log in screen

log in and restart you might need to download Unity from Software center but all should be good!!

hope it helps

share|improve this answer

protected by Community Jul 7 '12 at 9:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.