Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my Ubuntu 11.04 to 11.10 and my Wifi has stopped working. I have a Lenovo Z560 that has Intel centrino wireless-N 1000. I have searched various threads having similar problems for a solution and have no success. The wlan0 is not even showing up in rfkill. Please help me find a solution.

I am giving below the output of various debug commands. Thanks in advance.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"

----##uname -a

Linux gurucharapathy-laptop 3.0.0-17-generic-pae #30-Ubuntu SMP Thu Mar 8 17:53:35 UTC 2012 i686 i686 i386 GNU/Linux
----##lspci -nnk | grep -iA2 net
05:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1000 [8086:0084]
    Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN [8086:1315]
    Kernel modules: iwlagn
06:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
    Subsystem: Lenovo Device [17aa:392e]
    Kernel driver in use: r8169

----##iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

----##iwlist scan

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

----##rfkill list all

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

----##lsmod

Module                  Size  Used by
rfcomm                 38408  8 
bnep                   17923  2 
parport_pc             32114  0 
ppdev                  12849  0 
binfmt_misc            17292  1 
snd_hda_codec_hdmi     31426  1 
snd_hda_codec_conexant    52460  1 
uvcvideo               67271  0 
videodev               85626  1 uvcvideo
snd_hda_intel          28358  2 
snd_hda_codec          91859  3 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel
snd_hwdep              13276  1 snd_hda_codec
joydev                 17393  0 
snd_pcm                80435  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi           13132  0 
i915                  509554  9 
drm_kms_helper         32889  1 i915
snd_rawmidi            25241  1 snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
snd_timer              28932  2 snd_pcm,snd_seq
drm                   196290  5 i915,drm_kms_helper
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
mei                    36466  0 
mac80211              393421  0 
snd                    55902  14 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
ideapad_laptop         13575  0 
intel_ips              17753  0 
btusb                  18160  2 
i2c_algo_bit           13199  1 i915
soundcore              12600  1 snd
bluetooth             148839  23 rfcomm,bnep,btusb
cfg80211              172427  1 mac80211
psmouse                63474  0 
serio_raw              12990  0 
snd_page_alloc         14108  2 snd_hda_intel,snd_pcm
sparse_keymap          13658  1 ideapad_laptop
wmi                    18744  0 
video                  18908  1 i915
lp                     17455  0 
parport                40930  3 parport_pc,ppdev,lp
ahci                   21634  2 
libahci                25761  1 ahci
r8169                  47200  0 

----##nm-tool

NetworkManager Tool

State: asleep

Device: eth0 -----------------------------------------------------------------

  Type:              Wired
  Driver:            r8169
  State:             unmanaged
  Default:           no
  HW Address:        88:AE:1D:DE:5F:9C

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

----##lshw -C network

  *-network UNCLAIMED
       description: Network controller
       product: Centrino Wireless-N 1000
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:05:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:d6400000-d6401fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: eth0
       version: 02
       serial: 88:ae:1d:de:5f:9c
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.0.100 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:41 ioport:2000(size=256) memory:d2410000-d2410fff memory:d2400000-d240ffff memory:d2420000-d243ffff
share|improve this question
    
@Jorge Thanks for editing. But why all the new line characters from my posts are removed when I submit ? –  Timetraveler Apr 26 '12 at 3:52
    
You need to format your lines in Markdown, see here: askubuntu.com/editing-help –  Jorge Castro Apr 26 '12 at 3:57

2 Answers 2

Unfortunately, the N-1000 series doesn't work correctly on the 2.6 kernel. The current best work-around is to disable the card's wireless-N connectivity and operate on b/g only. It's not ideal, but it works.

Try doing

sudo modprobe -r iwlagn 
sudo modprobe 11n_disable50=1 11n_disable=1

To make the change permanent, add this line to your /etc/modprobe.d/iwlagn.conf file:

options iwlagn 11n_disable50=1 11n_disable=1
share|improve this answer
    
I tried your suggestion. The wireless is still not up. The card is still shown as unclaimed when I do lshw -C network. $ sudo lshw -C network [sudo] password for gurucharapathy: *-network UNCLAIMED description: Network controller product: Centrino Wireless-N 1000 vendor: Intel Corporation physical id: 0 bus info: pci@0000:05:00.0 version: 00 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list configuration: latency=0 resources: memory:d6400000-d6401fff –  Timetraveler Apr 26 '12 at 3:42
1  
Can you try the above suggestion with just the 11n_disable=1? I had an issue with this card on my Lenovo T410, same wifi NIC and that fixed my issue. Wrote it up on my blog –  slm Sep 3 '12 at 21:17

I don't know exactly way to solve this problem but in my friend case, he needs to type "rfkill block all && rfkill unblock all" then his wlan0 going to show up like a magic !

share|improve this answer
    
thanks for your suggestion, but that did not work. I think my wireless device is unclaimed still. –  Timetraveler Apr 26 '12 at 3:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.