Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 11.10 as virtual machine within Mac.

I have installed VM tools.

The approach in this link of Compizconfig Grid, which worked in my previous laptop where Ubuntu was not a virtual machine, does not work anymore. I set some shortcut, but no action is launched...

Does anyone know why?

The major functionality I need from Grid is tiling windows to left/right side of the screen... Does anyone know any alternative?

PS: I have tried other plugins of Compizconfig, for instance, Move Window works...

Edit1: The desktop environment I am using is Ubuntu, not Gnome. The unity is 2D instead of 3D. It is not a problem for me to change it if that can solve the Grid or tiling problem above.

Edit2 & 3: I didn't know that Unity2D does not use compiz by default... After installing gtk2-engines-pixbuf, I launched compiz --replace &in a terminal, that gives:

enter image description here

And I tried Grid once again: bind shortcut <Control><Alt>g to Put Left, it still does not work.

But as I said before, if I bind <Control><Alt>g to Initiate Window Move in Move Window (either before or after compiz --replace &), the shortcut always has an effect...

Edit 4: I just enabled Accelerate 3D Graphics, which was disabled before... But rerunning compiz --replace & in a terminal gives exactly same message as before including 2 Fatal for opengl.

enter image description here

share|improve this question
    
Thanks for your comment, I have updated the initial post... –  SoftTimur Apr 16 '12 at 12:15
    
Thanks, I have updated my post... –  SoftTimur Apr 16 '12 at 13:05
    
I have updated the initial post, there is still Fatal: GLX_EXT_texture_from_pixmap left, and I make sure that the unity plugin is not ticked. But still Grid does not work... –  SoftTimur Apr 16 '12 at 14:11
1  
... well done for continually updating your question. I dont have anymore ideas how to get the compiz Grid working in ubuntu-2D. Have you seen this question - and if so does any of the answers there give you the tiling capability you are looking for? askubuntu.com/questions/41566/… –  fossfreedom Apr 16 '12 at 14:35
1  
... sorry to return a question with a question - but I thought unity3D was not possible with VMTools - only virtualbox. If you can run unity3D then does the Grid work? - your question says you've only tested unity2D. –  fossfreedom Apr 16 '12 at 15:02

1 Answer 1

up vote 1 down vote accepted
+50

As I get it, *Fatal: GLX_EXT_texture_from_pixmap* means that X server does not support *GLX_EXT_texture_from_pixmap* API feature, which requires a 3D hardware acceleration.

You can see the previous error message: Fatal: Software rendering detected which means that VM has no configured 3D graphics acceleratio card, either because there is no such hardware in your system, or it's not properly configured.

So check out if there is 3D acc. card in the host OS, or not. If there isn't I guess you can't make Grid work. If there is, you should configure your VM to expose 3D acc. card to the guest ubuntu OS.

See Compiz hadware requirements.

share|improve this answer
    
Thanks for your comment... I have updated my initial post... the Fatal problems are still there, do you have any idea? –  SoftTimur Apr 16 '12 at 16:17
    
What kind of VM do you use? VMWare? VirtualBox? –  zuba Apr 17 '12 at 5:43
    
I use VMware Fusion –  SoftTimur Apr 17 '12 at 23:06
    
As you can see here(vmware.com/support/fusion2/doc/releasenotes_fusion_205.html) and here(kb.vmware.com/selfservice/microsites/…) some 3D acc. cards are not supported by VMWare Fusion. Finally that post(askubuntu.com/questions/122630/…) states that 3D graphics support for Linux guests is not available currently in VMWare Fusion. But you'd better ask VMWare support about that –  zuba Apr 18 '12 at 8:25
    
I can confirm that enabling 3d acceleration does allow grid to work on Ubuntu 12.04 VM (Workstation 9) under a Windows 7 host (on mba 2011) –  prusswan Jan 11 '13 at 9:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.