Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.10 32-bit version in dual boot mode on an ASUS K53. Every thing seems to work fine except for the wireless. The wireless works on Windows 7. Ubuntu finds the wireless card, but it does not appear to be turned on. The only physical means of turning on the card is the FN-F2 key combo. That works on Windows, but not in Ubuntu. I've looked in the forums for a solution and I'm not quite sure what to do. I've gathered the following information:

jdwbmc@Spatha:~$ cat /etc/lsb-release; uname -a
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
Linux Spatha 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux

jdwbmc@Spatha:~$ lspci -nnk | grep -iA2 net
02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
Subsystem: AzureWave Device [1a3b:1186]
Kernel driver in use: ath9k
--
04:00.0 Ethernet controller [0200]: Atheros Communications AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
Subsystem: ASUSTeK Computer Inc. Device [1043:1851]
Kernel driver in use: atl1c

jdwbmc@Spatha:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 058f:a014 Alcor Micro Corp. 

jdwbmc@Spatha:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID off/any 
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm 
Retry long limit:7 RTS thrff Fragment thrff
Power Managementff

jdwbmc@Spatha:~$ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no

jdwbmc@Spatha:~$ lsmod
Module Size Used by
parport_pc 32114 0 
ppdev 12849 0 
snd_hda_codec_hdmi 31426 1 
bnep 17923 2 
rfcomm 38408 0 
bluetooth 148839 10 bnep,rfcomm
snd_hda_codec_realtek 254125 1 
binfmt_misc 17292 1 
joydev 17393 0 
asus_nb_wmi 12469 0 
asus_wmi 19333 1 asus_nb_wmi
sparse_keymap 13658 1 asus_wmi
uvcvideo 67271 0 
videodev 85626 1 uvcvideo
snd_hda_intel 24262 2 
snd_hda_codec 91754 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel
snd_hwdep 13276 1 snd_hda_codec
snd_pcm 80468 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi 13132 0 
wmi 18744 1 asus_wmi
snd_rawmidi 25241 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event
arc4 12473 2 
i915 505108 3 
snd_timer 28932 2 snd_pcm,snd_seq
snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
ath9k 112711 0 
psmouse 73673 0 
serio_raw 12990 0 
mac80211 272785 1 ath9k
drm_kms_helper 32889 1 i915
ath9k_common 13599 1 ath9k
drm 192226 4 i915,drm_kms_helper
ath9k_hw 293893 2 ath9k,ath9k_common
ath 19387 2 ath9k,ath9k_hw
cfg80211 172392 3 ath9k,mac80211,ath
snd 55902 14 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,s nd_seq,snd_timer,snd_seq_device
soundcore 12600 1 snd
snd_page_alloc 14115 2 snd_hda_intel,snd_pcm
mei 36466 0 
i2c_algo_bit 13199 1 i915
video 18908 1 i915
lp 17455 0 
parport 40930 3 parport_pc,ppdev,lp
ahci 21634 3 
libahci 25727 1 ahci
atl1c 36638 0 
xhci_hcd 72915 0 

jdwbmc@Spatha:/var/lib/NetworkManager$ cat NetworkManager.state

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

jdwbmc@Spatha:~$ lspci -nn | grep 0280
02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)

Any help would be appreciated. Thanks.

share|improve this question

2 Answers 2

Try to implement these steps in this Launchpad comment of mine. Worked for my card, and possibly will work for yours too.

share|improve this answer
3  
It would be even better if you'd be willing to include the text of the Launchpad comment here as your answer (or part of your answer). –  Eliah Kagan Jun 3 '12 at 4:57

Solved! Installed linux-backports-modules-cw and network-manager update. Works well. linux-backports-modules-cw can be found in software center and network-manager update can be get via normal uodatin method. For anybody who needs this info in Tukish navigate to my blog entry : http://gkaya93.blogspot.com/2012/05/ubuntu-1204-wireless-cozumu.html . I will write an English description here:

  • Check the table in this page to see if your wireless card (or sth similar*) is there : http://wiki.ubuntuusers.de/WLAN/Linux-backports-modules#Enthaltene-Treiber
  • If there, do the following:
  • Go to terminal and enter "uname -r" for returning kernel version.
  • Search for a matching version of "linux-backports-modules-cw" in software center. Install it.
  • Update network-manager.
  • Reboot and see if it affects. It changed my experience a lot. It's really better now.

*My card was rtl8192se. It wasn't included in the table, instead, rtl8180/rtl8187. but the software healed my system. So go ahead and try if your card's model is close to included models. I guess this is safer than manipulating system configuration files.

And sth to include, on the website, it says that linux-backports-modules-cw is included in the Live image, so you can install if have no connection. I didn't try it, as I have formatted my live medium. But if you didn't, add it to your Software sources and try to use. - Software Center > Edit > Software sources > Installable from CD-ROM/DVD... Check the checkbox below it.

I guess this thing would work well in elderly Ubuntu versions, but I'm not sure and encouraging anyone to try it because of my word. Thanks for any support made.

share|improve this answer
    
Post output of "iw reg get" and "iw phy phy0 wlan0" –  BigSack Jun 16 '12 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.