Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Xmonad and LXDE, so I don't want to use gnome-settings-daemon. But there is a problem - without it I cannot switch into or type in Cyrillics. I found some temporary solution - when I enter sudo dpkg-reconfigure keyboard-configuration and click through config menu, I end with right layout. But after I reboot system it disappears and I am forced to reconfigure it again. Is there a way to make this changes permanent?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

Yes edit /etc/default/keyboard to set the global settings or ~/.dmrc for per-user settings.

Example /etc/default/keyboard:

 XKBMODEL="pc105"
 XKBLAYOUT="fr,us"
 XKBVARIANT="oss"
 XKBOPTIONS="compose:ralt,terminate:ctrl_alt_bksp"

Example ~/.dmrc:

 [Desktop]
 Language=de_DE.UTF-8   # change to your default lang
 Layout=de   nodeadkeys # change to your keyboard layout

In either case, will need to also run:

 sudo udevadm trigger --subsystem-match=input --action=change
share|improve this answer
    
Can you explain what the last step does in detail and why one needs it? –  student Apr 24 at 14:57
1  
udev is the service that manages your devices. The command signals to this service that there's been a change to your input subsystem and that it should re-detect things and reconfigure. Rebooting your system should have the same effect. –  Bryce Apr 24 at 19:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.