Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I really like wiggle animation for application notification, but I find it disappear too quickly and I wish I could change this delay. I looked through all the ccsm, appearance, and myUnity settings and nothing seems appropriate.

share|improve this question
1  
Nice question! Wiggle thing is too fast to really draw the user's attention –  Mysterio Apr 12 '12 at 23:45
    
You can also go vote for these bugs: Unity's sidebar Urgent icon animation not constant and Launcher icon alert animation should repeat.... (Click on the pencil and say "Yes, it affects me".) –  Mikel Nov 18 '12 at 18:04
add comment

1 Answer

up vote 4 down vote accepted

I don't think this is a configurable option in Unity, but you can edit the source code to change the duration. If you've not downloaded source and compiled your own packages before, you can do so as follows. From your home directory in a terminal window:

mkdir src
cd src
apt-get source unity
cd unity-<version number>
gedit ./plugins/unityshell/src/Launcher.cpp

Look for the line which says:

Launcher.cpp:const int Launcher::Launcher::ANIM_DURATION_SHORT = 125;

and maybe double the duration. If you've never built a package from source before you're going to need a few tools. So do:

sudo apt-get install build-essential devscripts

Then to get the dependencies neccessary for unity to build properly:

sudo apt-get build-dep unity

Finally create the package and install:

debuild -us -uc
cd ..
sudo dpkg -i unity*.deb

If you're having problems with dependencies let me know, and I'll try to help you figure out what you're missing.

share|improve this answer
    
Never got notify of the answer here. First of all, Launcher.cpp is now in unity-.../launcher/ folder, but I found it and updated the variable there. Then on the last step I was missing some dependencies and I was able to resolve them with apt-get -f install. Eventually I got stuck on dpkg: dependency problems prevent configuration of unity: unity depends on libunity-core-6.0-5 (= 7.0.0daily13.04.18~13.04-0ubuntu1); however: Version of libunity-core-6.0-5 on system is 7.0.0daily13.04.18~13.04-0ubuntu1systray1. –  Vitaly Jul 10 '13 at 22:14
    
This Patch is only increasing the animation duration and not the wiggle time. To be clear: With an higher integer in ANIM_DURATION_SHORT, the wiggle animation gets slower. So it does only wiggle 2 times before it fades after a second where it did 6 wiggles before in one second. (time and quantity of wiggles is exemplary. I did not measure time and number of wiggles exactly.) –  mondjunge Oct 30 '13 at 14:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.