Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's my first ask here, so sorry for something... I have a notebook ( 3Gb Ram, Core 2 Duo @ 2,1Ghz , Intel Graphics 4 1GB Onboard) and when I open more than 3, 4 softwares, and try to alternate between them, using the "Super + W" , I got some legs and low performance. sometimes the Unity crash and restart because. While watching some videos on Youtube, and open the Dash, the "transparency" behind Dash looks very Legged, sometimes the image Freeze behing the Dash layer. When I was a Windows 7 user, I could open 10 softwares and alternate between 'em using "Super = Tab" without any troubles. I was able to Play Burnout Paradise, a heavy game, with aero Turned ON! This way I believe this trouble is with the default driver came with ubuntu 11.10 (and 12.04). While using Ubuntu 10.10, this didn't happien. So , My question is.... Is there some driver I can Download to improve my video's board speed? Can I do something?

P.S. = I prefer the workflow Unity, It's easier, prettier and agiler than Windows 7 UI

P.S. 2 = Sorry about my bad english, I'm Brazilian, and here just about 5% can speak english. "I didn't use google translator :P)

Thanks for the answers :D God blesses you!

share|improve this question
add comment

2 Answers

What you could do, first, is use Unity 2D. Unity 2D isn't really behind Unity 3D, so you would get better performance and still be able to use Ubuntu as it's.

A second option would be use xorg-edgers, a PPA that updates your drivers to the latest ones avaiable. But those are EXPERIMENTAL drivers and are dangerous, so only use it if you are absolutely sure you want to use them. As they say: this PPA can put your computer on fire hehe

Since you are from Brazil, you can read this article i wrote about xorg-edgers.

Hope it helps you, but again: xorg-edgers have EXPERIMENTAL and not tested drivers and can break your desktop, so only use if you know what you are doing. I never had any problem with it (Intel HD 3000 Sandy Bridge), but i have to warn you that i can give you trouble.

share|improve this answer
add comment

open jocky-gtk(default installed), check is there are any suggestion for graphics driver? if any install it. Otherwise these step maybe help,

open /etc/default/grub file

sudo gedit /etc/default/grub

change the line

GRUB_CMDLINE_LINUX="" to  GRUB_CMDLINE_LINUX="nomodeset"

update grub

sudo update-grub

Reboot

share|improve this answer
    
nomodeset disables the Intel driver which forces a 1024x768 VESA resolution –  Lekensteyn Apr 12 '12 at 21:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.