Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed ubuntu 11.10 on my x120e using amd64 alternate iso image. The installation went fine, but it is having issues while booting after a successful installation, it says - "No Operating System Found". I followed the instruction at - to purge grub-efi and installed grub-pc, even then I couldn't boot into ubuntu.(got the same "No Operating System Found") This is the file from boot-repair with this setup -

Then I asked in #ubuntu and they suggested me to create a bios-boot partition, I was not very comfortable with the solution they had suggested but gave it a try anyhow. I re-sized my initial partition and made 4 MB free space in the beginning of the partition and had set the flag bios_grub. Re-installed ubuntu 11.10 this time using amd64 desktop iso image file. Installation went fine as before but finally this time also the system didn't boot, it gave the same - "No Operating System Found" message.

In BIOS I have the settings as to use both (Legacy and UEFI) and with UEFI tried first. This is the boot-repair file from my latest setup -

Any help/suggestions are appreciated.

share|improve this question

I found that all these trouble were due to the GPT partition written to my disk instead of MBR and I had replaced grub-efi with grub-pc. Grub was looking for the bios_boot partition since my GPT string was telling it the system doesn't use EFI, I had setup a 4 MB bios boot partition and it didn't worked even after repeated attempts trying out things with GParted and book-repair.

I started with a fresh install, but this time I had disabled the UEFI support in BIOS before the installation and only enabled the Legacy option. This time the system had no chance to mix up things and I got my system to boot after the installation.

ps: I installed using the alternate amd64 iso, since desktop amd64 iso stuck in between installation.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.