Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Precise, window auto-maximize is disabled on monitors with a resolution above 1024 × 600 [1]. I have a bigger resolution, but I prefer maximized windows anyway. I want Update Manager to start maximized.

What I've tried so far:

  1. In Compiz Config Settings Manager, I have Place Windows activated and 'Windows with fixed placement mode' has windows matching the rule "(name=gnome-terminal) | (name=update-manager)" set to 'Maximize'. With this, Gnome Terminal starts maximized, Update Manager does not.
  2. In Compiz Config Settings Manager, I have set a Window Rules [2] rule to match "name=update-manager". Irregardless of any rules set or not, activating Window Rules results in not being able to bring out Unity Launcher anymore, Alt+Tab window switching becoming slow or nonfunctional entirely and the screen sporadically freezing completely. Not a viable option apparently.
  3. I've installed Maximus [3] and started it. Update Manager ignores it (or vice versa).

I've not tried devilspie and would prefer not to. Having to configure something external for this would seem stupidly redundant with (the no-brainer) Maximus and all these Compiz options already available. I just can't seem to make them work.

Edit: For some time now, I've had the 2nd solution above (Window Rules) in use, and the Unity-related problems have no longer manifested themselves; apparently the related bugs have been fixed (although I've only found one expired bug from Launchpad that seems to describe the issues I had [4]). I'm therefore closing this.

share|improve this question
    
Never got Compiz to do the job, so I'm closing this as Eric suggested. FWIW, this devilspie script seems to work: (if (matches (application_name) "^update-manager$") (maximize)) –  Jani Uusitalo Jun 14 '13 at 7:33
    
Uh, except there's no "abandoned" alternative in the closing alternatives, and the question is still valid. –  Jani Uusitalo Jun 14 '13 at 7:39
    
Abandoned questions are usually closed as "Too localized", but if you're still looking for an answer there's no need for closing it. –  Eric Carvalho Jun 14 '13 at 8:31
    
Okay, thanks for the advice Eric. I do intend to post here if I do come across a solution, so I'll keep this open for now. Software updater in current releases looks different, so I'll probably close this in any case once the next LTS comes around and I've upgraded. –  Jani Uusitalo Jun 14 '13 at 12:22
    
Have this ever got solved? –  Braiam Feb 25 at 0:39
show 1 more comment

closed as off-topic by Jani Uusitalo, Braiam, Eric Carvalho, Minato Namikaze, Seth Feb 25 at 18:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, Eric Carvalho, Minato Namikaze, Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.