Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When setting up a VPN connection using the UI (System settings => Network) the VPN connection is used as the default route after connecting to it.

How can I avoid this? That is without assigning manual addresses. I want the connection to use DHCP. It should use the eth* interfaces for my default route, like they are used before making the connection. The VPN route should only be used when connecting to addresses in the ppp0 adapters range.

If possible using the GUI only, not that I'm not used to editing config files...

I tried setting the "Method" combobox in the "Configure..." dialogue to "Automatic (VPN) addresses only". That doesn't make a difference.

(Another thing I noticed; the UI shows my connection as a "Wireless connection" in the list control on the left. Don't know why... it has the right icon, but that's probably something for the bug tracker.)

share|improve this question
add comment

1 Answer 1

up vote 5 down vote accepted

In your VPN connection settings, tick the box 'use this connection only for resources on its network'

enter image description here

share|improve this answer
1  
I will have my eyes checked...! Thanks duffydack, confirmed working. –  Pieter Pabst Apr 12 '12 at 18:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.