Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using the latest edition of Virtualbox 4.1.12 and I get the attached when I attempt to launch Unity. Everything is running in the background but it's not displaying the launcher, dash, or panel. Just a long line at the top of the screen.

I've tried to reboot the VM as well as ensure all updates are installed. I've also tried removing and reinstalling the Guest Additions. See screenshot below:

enter image description here

Please note that the possible duplicate does not describe the same problem. That fix is not appropriate as Unity is in this case actually running but not displaying properly.

share|improve this question
    
    
I have reviewed the above posting and none of those fixes are resolving my issue. I noticed that none of those posts speak to the users running VirtualBox. I am still having this issue...can additional help be provided please? –  Scooby7 Apr 19 '12 at 13:15
    
I found out that on my computer when running Virtualbox in 1366x766 fullscreen mode... I can not use autohide the icons... they are placed outside my left border of the screen if I activate it...thus I cant make them reappear by touching the left border. They seem to be about 40 pixels outside as if I set up the icon size to 40 or more I can see the partiall icons poping out when they start wiggling. If I change to not auto-hide by system settings they reappear (in correct positions). Ubuntu 12.04 under Win 7 Home with VirtualBox 4.14r4770 Hope this gives more info on the "bug" ... –  user64090 May 17 '12 at 10:03
    
I want to add that I'm currently experiencing this with 12.04 LTS and the latest Vbox. In my case, it didn't happen until after I had installed the extensions. shrug. –  user81363 Aug 5 '12 at 0:39

3 Answers 3

You also need the extension pack to work properly http://download.virtualbox.org/virtualbox/4.1.12/Oracle_VM_VirtualBox_Extension_Pack-4.1.12-77245.vbox-extpack

share|improve this answer
    
Other than the Guest Additions the Extension Pack should not be needed for running 12.04. –  Takkat Apr 13 '12 at 6:24

Try unchecking the "Enable 3D acceleration" feature in Virtualbox under Settings --> Display. It worked for me.

share|improve this answer
    
Thanks A LOT!! worked like a charm! –  Naama Katiee Aug 16 at 19:41

I had the exact same problem and stumbled across this question while trying to figure it out. I managed to fix it by comparing it to a pre-configured distro I had already been running in order to use KDEnlive in Windows, which worked fine.

I noticed that 3D acceleration was unchecked on that, and that PAE/NX was enabled, so I made those changes and Unity shows up fine. It runs very slowly, but it shows up!

Hope this helps anyone who is still looking for the answer (or even the OP if he is still stumped by this) :)

share|improve this answer
    
As you mentioned - it makes Unity very slow. Disabling 3D acceleration with Ubuntu 12.10 or newer where Unity 2D is not present anymore makes GUI useless. –  Ladislav Mrnka Apr 7 at 15:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.