Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to centralize my executables and libraries but I still want to be able to execute an input file from anywhere in the file tree without having to copy in the executable and the library every time.

Now I centralized everything in /home/HobbsFolder/bin added PATH=$PATH:/usr/lib/pvm3/lib:/home/HobbsFolder/bin/ to the .bashrc. Checking with echo $PATH shows the expected path. Starting the executable from a random folder works, as long as the library is placed in the folder, where the computation is started.

So, for some reason the system finds the executable but not the library in /home/HobbsFolder/bin/. I tried placing it in /usr/local/lib and running ldconfig, which to my understanding is supposed to generate a link, but ldconfig -v shows no such thing.

I don't have access to the binaries so I can't recompile anything. The system classifies the file-type as unknown.

Is there any correct place for placing external libraries? What can I do to make the system understand that this is not just some random text-file or something and it is supposed to look in THIS folder when I execute that executable?

share|improve this question

closed as too localized by qbi, Seth, Eric Carvalho, AgentCool, Mitch Mar 1 '13 at 6:01

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What is the output of ldd in one of the executables in your home? –  qbi Feb 28 '13 at 23:45
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Seth Mar 1 '13 at 0:06

Browse other questions tagged or ask your own question.