Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop is 1G ram and 120G hard-disk 1.68HZ processor , I've both Ubuntu and Windows7 on my machine

For the last few days, my laptop, running Ubuntu 11.10 has been hanging a lot. A lot of the time, the touchpad won't work for unknown reasons, and I have to connect a USB mouse to be able to move the pointer on the screen. When browsing the web, the browser hangs a lot, and I have to restart the laptop to refresh it. I know that there is a hotkey to force Ubuntu to refresh when it hangs, but it doesn't work here.These problems happens only on ubuntu not on windows 7... How do I make Ubuntu light and fast? Help me, please.

share|improve this question
    
No logs - no candy. –  Andrejs Cainikovs Apr 12 '12 at 10:16
    
Possibly any background processes are running? Check with top in a terminal or use gnome-system-monitor. –  Jakob Apr 12 '12 at 11:05
    
You also could check if these problems appear in other sessions, too ("Ubuntu 2D" or Gnome, Cinnamon ... if installed). –  Jakob Apr 12 '12 at 11:15
    
on the system monitor >>> there are a lot of process "sleeping" and the cpu usage is about 95% –  Salahuddin Apr 12 '12 at 11:41
    
So I guess there is one process which uses a high percentage of your CPU. Which one? You can sort the processes by clicking on the title of the CPU-column. –  Jakob Apr 12 '12 at 11:50

2 Answers 2

If you allow Ubuntu to upgrade or update to the latest version, this can sometimes help. Unfortunately the 'restore to last known working' system is not implemented.

You might to remove some programs, apps, etc. Then reboot and re-install these same ones, rebooting again. It often works.

With whatever programs you are running in Ubuntu now, you may be running out of both memory and disk space.

Try remove unnecessary files, programs and background applications. Avoid multi-tasking and very demanding programs.

share|improve this answer

It might be worth a try to disable your desktop effects first. (Go to Top-Left corner of the screen, click preferences, click appearance, Click the tab in the window that has appeared labelled "Visual Effects", click the "No Effects" option.)

Also, go to the terminal and run dmesg (Press ALT-F2, Type "gnome-terminal", and enter dmesg > ~/Desktop/dmesgout.txt)

Then go to your desktop, open the dmesg file and copy and paste to the forums.

Thanks, SM

share|improve this answer
    
There are a lot of text found in this file Here are some of them [ 0.000000] Initializing cgroup subsys cpuset [ 0.000000] Initializing cgroup subsys cpu [ 0.000000] Linux version 3.0.0-12-generic (buildd@vernadsky) (gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3) ) #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 (Ubuntu 3.0.0-12.20-generic 3.0.4) [ 0.000000] KERNEL supported cpus: –  Salahuddin Apr 12 '12 at 11:34
    
on the system monitor >>> there are a lot of process "sleeping" and the cpu usage is about 95% –  Salahuddin Apr 12 '12 at 11:40
    
paste.ubuntu.com/926314 here the full text generated –  Salahuddin Apr 12 '12 at 12:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.