Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have my laptop connected to a monitor via VGA. When I start the computer up, the login screen shows on both the monitor and laptop screens, and is not the correct resolution. I would like it to show up only on the monitor screen, and to be 1920x1080. Any suggestions?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

If you want your multi-monitor system to boot up with a spanned desktop rather than each output being a mirror of the others, you will need to configure the X server manually. You can do this with a fairly minimal /etc/X11/xorg.conf file. For example, on my system it consists of only:

Section "Device"
        Identifier      "ATI Technologies Inc Juniper [Radeon HD 5700 Series]"
        Driver          "ati"
        Option          "monitor-HDMI-0" "DELL U2311H [1]"
        Option          "monitor-DVI-1"  "DELL U2311H [2]"
EndSection

Section "Monitor"
        Identifier      "DELL U2311H [1]"
        Option          "LeftOf"        "DVI-1"
        Option          "Primary"       "true"
EndSection

Section "Monitor"
        Identifier      "DELL U2311H [2]"
EndSection

This configures the two screens to span with the one connected to the HDMI-0 output as the primary and left of the output connected to DVI-1. With this video card/monitor combination the resolution gets detected correctly. If the best mode is not automatically picked, you might need to specify the PreferredMode option in the relevant monitor section.

Full documentation can be found in the xorg.conf manual page.

share|improve this answer
    
I haven’t tried it, but in an Ubuntu 12.04 review I read that you should now be able to configure a spanned desktop from the configuration screen UI. –  Laurens Holst Apr 28 '12 at 0:35
add comment

There's a really cool little program that helps with this it called "lxrandr"

Install from the Ubuntu Software Center.

enter image description here

share|improve this answer
    
Thanks but I tried it to no avail. When I boot up the login screen still shows on both with the incorrect resolution. –  wotte3 Apr 12 '12 at 4:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.