Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can i set my laptop with ubuntu 10.04 to autoconnect to Wi-Fi (with pass, WPA2-Personal), when i on my laptop without asking password on wi-fi? I wont on my laptop and start surfing without enter pass of my wi-fi.

share|improve this question
add comment

4 Answers

You must be logged-in to get a network connection with NetworkManager.

One ugly workaround is to configure the gdm to auto-login, this poses a security threat if someone can physically access your laptop.

System > Administration > Login Screen

alt text

Unlock and select "Login as automatically"

share|improve this answer
    
This will mean that you have to enter your password for some services e.g Liferea as your passwords are still kept secure. –  Adam Nov 8 '10 at 15:52
add comment

You'll want to follow the instructions in this thread -

http://ubuntuforums.org/showthread.php?t=263136

Basically, it comes down to:

1) Generate a PSK via wpa_supplicant

2) Modify /etc/network/interfaces to use your network settings.

A sample:

iface eth0 inet static
address 192.168.1.15
netmask 255.255.255.0
wireless-essid my_essid
gateway 192.168.1.1
scan_ssid=1
proto=WPA RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP
psk=your_psk
share|improve this answer
    
I don't think that's right. I don't have to enter a password and I didn't do all this wpa_supplicant gubbins. I think this is a problem that can be solved without resorting to circumventing all those years of user experience work in ubuntu. :-) –  Stefano Palazzo Nov 8 '10 at 15:57
    
Well, this way avoids using the keyring at least - I always have trouble with the network-manager daemon anyway. If vanilla network-manager wasn't doing autoconnection for him, then this method is probably all he needs. Set it up once and don't worry about it any more :) –  javanix Nov 8 '10 at 16:01
    
You may well be right. I'm just a bit frustrated with people following complex howtos that mess with the oily bits of the operating system, only to then realise they've messed up, when indeed all they needed to do was click a few buttons and do it "like they were supposed to". The best example of this is people updating to the next ubuntu release by just changing all the "lucid"s to "maverick" in their sources.list file - which completely messes up the update, but not so as you'd notice right away. Don't attribute to bugs what can easily be explained by a misunderstanding. :) –  Stefano Palazzo Nov 8 '10 at 16:13
1  
Oh, very true in most cases. I had been fighting this same issue all week as it happens so I was just excited to share what I got working :) –  javanix Nov 8 '10 at 16:54
add comment

You'll need to provide a bit more information!

Here is my stab at it anyway:

Right click on the networking icon, select "edit connection.." and choose the connection you want to automatically connect with. Make sure the connection has got the password saved (enter it in the security tab), then select "available to all users" (or something along those lines, check box in the lower left) and click apply.

Network Manager will now no longer ask you for a password for this connection. The Gnome Keyring Manager should not ask you either, given you're logged in. If it keeps asking, perhaps another application is requesting a password?

Edit: I just noticed the big check box right under the name of the network, in the "edit connection" dialog, where it says: "Connect automatically". I presume it's enabled. Notice, you can check this box on multiple connections.

share|improve this answer
add comment

Do you mean your WiFi key or user password. The key is stored like a password, so if you use auto login, you may need to enter your password to gain access.

You can stop the password request by opening System->Passwords and Encryption Keys

Select Passwords:Login from the passwords tab Right click and select change password Change the password to blank

I wouldn't recommend it, but if you are happy with the reduced security it is OK.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.