Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i use to have when i have the computer turn on and was idle having more than 2 tasks running at same time.. but now this is not happens and it is enable at maximum of 2 tasks at same time, i don know why.

also i was able 2 do that on ubuntu 11.10 not sure if is the same using boinc on ubuntu 11.10.

so why this happens?

and how can i set up boinc 2 run more than just 2 tasks at same time in ubuntu 12.04 beta?

share|improve this question

The number of simultaneous tasks depends on the number of CPU cores you have. A quad-core CPU will run 4 tasks (and an extra 5th task if you have a GPU), a dual-core will run 2, etc.

Each task runs on each CPU core, and there is little point in running additional tasks beyond your CPU core count: they won't run any faster, and might run slower due to polling/switching.

share|improve this answer

Same thing happened for me on 2 different 4-core Xeons, and a 6-core AMD Phenom. Turns out there is a setting in /var/lib/boinc-client/global_prefs.xml:


After changing that to 4 resp. 6, and sudo service boinc-client restart, all my cores were used.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.