Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install the mumble-server package using apt-get install mumble-server on Ubuntu 11.10 Server Edition on Rackspace Cloud.

Problem is it can't find dependencies it should have found because they exist on launchpad.net?

Dependencies message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mumble-server : Depends: libavahi-compat-libdnssd1 (>= 0.6.16) but it is not     installable
             Depends: libprotobuf7 but it is not installable
             Depends: libqt4-dbus (>= 4:4.5.3) but it is not installable
             Depends: libqt4-network (>= 4:4.5.3) but it is not installable
             Depends: libqt4-sql (>= 4:4.5.3) but it is not installable
             Depends: libqt4-xml (>= 4:4.5.3) but it is not installable
             Depends: libqtcore4 (>= 4:4.7.0~beta1) but it is not installable
             Depends: libqt4-sql-sqlite but it is not installable
E: Unable to correct problems, you have held broken packages.

Any ideas on if I might be missing sources? I've been googling around and haven't found anyone else in this situation or anyone else not able to install the aforementioned packages. Thanks for your time!

sources.list:

deb http://mirror.rackspace.com/ubuntu/ oneiric restricted
deb-src http://mirror.rackspace.com/ubuntu/ oneiric restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://mirror.rackspace.com/ubuntu/ oneiric-updates restricted
deb-src http://mirror.rackspace.com/ubuntu/ oneiric-updates restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://mirror.rackspace.com/ubuntu/ oneiric universe
deb-src http://mirror.rackspace.com/ubuntu/ oneiric universe
deb http://mirror.rackspace.com/ubuntu/ oneiric-updates universe
deb-src http://mirror.rackspace.com/ubuntu/ oneiric-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://mirror.rackspace.com/ubuntu/ oneiric multiverse
deb-src http://mirror.rackspace.com/ubuntu/ oneiric multiverse
deb http://mirror.rackspace.com/ubuntu/ oneiric-updates multiverse
deb-src http://mirror.rackspace.com/ubuntu/ oneiric-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the  release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://us.archive.ubuntu.com/ubuntu/ oneiric-backports restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-backports restricted universe     multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb http://archive.canonical.com/ubuntu oneiric partner
# deb-src http://archive.canonical.com/ubuntu oneiric partner

deb http://security.ubuntu.com/ubuntu oneiric-security restricted
deb-src http://security.ubuntu.com/ubuntu oneiric-security restricted
deb http://security.ubuntu.com/ubuntu oneiric-security universe
deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse

# Cool Kid Webmin/Usermin Here Brah

deb http://download.webmin.com/download/repository sarge contrib
deb http://webmin.mirror.somersettechsolutions.co.uk/repository sarge contrib
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Fixed by replacing the Rackspace mirrors with default Ubuntu URLs found at: http://repogen.simplylinux.ch/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.