Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I put certain windows on certain spaces, but prefer alt-tab to switch between them. Is there a toggle or other option to turn on the alt-tab from all workspaces in unity?

share|improve this question

3 Answers 3

up vote 25 down vote accepted

enter image description here

In 12.04, the switcher defaults to those windows co-located on one workspace/viewport.

You have a couple of options in ccsm

enter image description here

You can untick the bias option which will show windows in all workspaces.

Alternatively, you can use add CTRL to your ALT+TAB to achieve the same effect

share|improve this answer
    
Great. That Did it - uncheck the bias. Thanks. –  blackhawkover Apr 11 '12 at 20:40
    
Just for the record, to find this panel, you need to open the Ubuntu Unity Plugin in the compiz manager –  chrismarx Jan 22 at 17:09

CompizConfig Settings Manager is deprecated, another tool to use is gconf-editor.

Navigate to

/apps/compiz-1/plugins/unityshell/screen0/options/

and set the proper key bindings for alt_tab_forward and alt_tab_forward_all. By default, Ctrl+Alt+Tab switches between windows on all workspaces, and Alt+Tab between windows on current one. I'd just swap them.

Or from the command line:

gconftool --set --type=string /apps/compiz-1/plugins/unityshell/screen0/options/alt_tab_forward_all '<Alt>Tab'
gconftool --set --type=string /apps/compiz-1/plugins/unityshell/screen0/options/alt_tab_forward '<Control><Alt>Tab'

You may also want to fix alt_tab_prev and alt_tab_prev_all accordingly (I personally never use them).

share|improve this answer
    
gconf is being phased out itself in favor of dconf. –  Seth Mar 12 '13 at 14:37

No-new-software based solution:

Based on Yevgen Yampolskiy's suggestion in Alt-Tab does not switch , I renamed the .gconf* and .gnome2* folders in my home folder to ..gconf* and ..gnome2*, logged out, and back in.
Problem solved. By the way, I had been using 12.04 for 8 months until this problem struck after I stupidly did sudo service lightdm restart from an F1 console session. Stupidly, because I was running gnome classic without effects.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.