Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try adding this movie file to Pitivi I get the following error (I can play the file in mplayer just fine though):

Problem: An internal error occurred while analyzing this file: Could not find GStreamer caps mapping for FFmpeg codec 'h264', and you are using an external libavcodec. This is most likely due to a packaging problem and/or libavcodec having been upgraded to a version that is not compatible with this version of gstreamer-ffmpeg. Make sure your gstreamer-ffmpeg and libavcodec packages come from the same source/repository. Extra information: gstffmpegdec.c(1336): gst_ffmpegdec_negotiate (): /GstPipeline:Discoverer-file:///media/Data/pitivi/taw2.mkv/GstDecodeBin2:dbin/ffdec_h264:ffdec_h2645

Also, my system language is English, but regional format is set to German. mplayer installed in German, I want it in English though...

Thanks a lot for your help :) I know I'm a noob >.>

share|improve this question

closed as too localized by fossfreedom Dec 30 '12 at 9:40

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Hi, can you provide the versions of Ubuntu, mplayer and pitivi? Maybe you could try enabling the restricted sites of the repositories. You can see this similar problem: askubuntu.com/questions/66811/cant-play-mkv-files –  Christian Vielma Apr 11 '12 at 18:07
    
thanks for your reply =) installing ubuntu restricted extras did not help, the error msg remains unchanged... i'm on ubuntu 11.10, pitivi is 0.15.0 and smplayer is 0.6.9 btw, there are some mkvs i can play just fine anywhere and some that only work with smplayer... (also, same problem on win7, only wmplayer played those files properly) –  niku Apr 11 '12 at 20:23
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  Seth Dec 30 '12 at 6:57
add comment

Browse other questions tagged or ask your own question.