Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am Using Linux for the very first time And i have one question. Dunno if it will be answered,but i hope so.. I have fujitsu ah 530 with intergrated video card(INTEL HD) so can i play my fav game on linux? And how to do it?

I installed it via Wine,but when i am starting the game with It,the game windows shows soooo poor,its unplayable,i can take i screenshot.

Here's a screenshot of what I'm experiencing: menus

share|improve this question
    
It sounds to me like you need to tweak wine. I hear good things about playonlinux. I haven't used either for gaming, but I've seen screenshots of warcraft on linux. –  hbdgaf Apr 11 '12 at 11:42
1  
@DarKoza Please try to run the game with Unity2D (session: Ubuntu2D) instead of running with Unity3D, Unity3D uses OpenGL and might the reason why its conflicting with the game. –  Bruno Pereira Apr 11 '12 at 11:58
    
And i have one more question.I think this is the problem Of not displaying the game menu correctly.i went to command line by ctrl alt T and then whore lspci,and in the listing theres no such thing as VGI controller,seems that linux doesn't recognize my video card.. –  DarKoza Apr 11 '12 at 12:13
add comment

2 Answers

up vote 4 down vote accepted

Try forcing OpenGl mode in the game when you start it.

For a quick test you can just open a terminal (Ctrl+Alt+t) and type this to start the game forcing OpenGl

wine ~/.wine/drive_c/Program\ Files/Warcraft\ III/Frozen\ Throne.exe -opengl

If it works, drop a comment so we can find a more permanent solution

share|improve this answer
    
Back in the day, I remember playing Warcraft III under either Cedega or Wine by using the -opengl flag for this reason - so this is quite likely to work. Alternately it could be the other way around and you might need to force DirectX mode. Try both. –  Li-aung Yip Apr 11 '12 at 15:34
add comment

As some stated in the comments, both playonlinux and wine says that W3 TFT should run fine under linux (playonlinux docs, wine docs).

I would try to install playonlinux (here) first and see if that helps.

share|improve this answer
    
Ah at last,Thanks.I'm In my world Now -_- Bruno Pereira especially. U're Gr8 Guys. I'm damn happy right Now. Open gl Mode solved It totally, I think that Wc3 Now runs better Than On win 7 LoL :D –  DarKoza Apr 11 '12 at 16:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.