Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I know this has been asked but on slightly different terms. I would like to remove it so that I can see the code behind. Not one off but every time it is shutdown and started. Thaknk you in advance.

share|improve this question

marked as duplicate by Jorge Castro, Kevin Bowen, Mik, Luis Apr 12 '13 at 4:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

up vote 9 down vote accepted

I recommend just editing your /etc/default/grub.

Change

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"  

to

GRUB_CMDLINE_LINUX_DEFAULT=""

Remember to update grub afterward with sudo update-grub at the command line.

Comment: Originally, I put GRUB_CMDLINE_LINUX_DEFAULT="text". Note this will end your boot process at the command line. After (possibly) having to login with username and password, startx at the prompt will start up your usual GUI.

share|improve this answer
1  
Thank you so much. Just what i wanted. –  Luke Apr 11 '12 at 6:10
    
This made my Ubuntu loose all the x GUI not the splash. –  Hilmi Erdem KEREN Apr 11 '12 at 19:53
    
@Luke I'm glad it helped. I hope you didn't run into a problem like the others. See my revised answer. –  Chan-Ho Suh Apr 11 '12 at 23:24
    
@erdemkeren See my edited answer if you need to get back into the GUI. Alternatively, you can edit your grub again using the nano editor, which is a friendly console-based editor. –  Chan-Ho Suh Apr 11 '12 at 23:37
    
No problem about recovering. Just wanted to inform others. Thanks for reply. –  Hilmi Erdem KEREN Apr 12 '12 at 21:58

For a single boot process, you can interrupt Grub e (edit), move the cursor to the kernel you want to start, e edit the line with the kernel and remove the

splash quiet

or change them to

nosplash noquiet

A persistent solution would be to modify your /boot/grub/menu.lst file from:

kernel      /boot/vmlinuz-2.6.32-39-generic root=UUID=01-cafe ro quiet splash locale=de_DE

to:

kernel      /boot/vmlinuz-2.6.32-39-generic root=UUID=01-cafe ro locale=de_DE

(your locale might vary). After installing a new kernel, the new one will again have the default settings. Modify in /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="noquiet nosplash"

if you have such a file. See

info grub 

on how to change your grub settings in general. There is a graphical customize for grub: https://launchpad.net/grub-customizer but I haven't tested it.

share|improve this answer
    
menu.lst is gone a very long time ago... –  enzotib Apr 11 '12 at 5:41
    
Thank you for your replies.. –  Luke Apr 11 '12 at 6:21
    
@enzotib: menu.lst is present in 10.04, the current LTS version of (X/K)ubuntu. It isn't gone, and it isn't gone long ago. –  user unknown Apr 11 '12 at 9:50
    
@userunknown: from Grub2: "GRUB 2 is the default boot loader and manager for Ubuntu since version 9.10 (Karmic Koala)". Maybe you have chosen to stay with grub legacy. –  enzotib Apr 11 '12 at 12:56
    
@enzotib: Afaik, with Grub2 the way the menu.lst file is modified has changed, but the file is still in use. I'm always updating my Linux installation and my /etc/grub.d dir is from 4.2010. The 20_memtest86+ file therein contains the note: older versions of grub2 do not have this yet (LP: #459080) so my impression is, that I'm using a kind of grub2. /etc/grub.d wasn't there with the former grub. –  user unknown Apr 11 '12 at 16:44

Me too: I wanted to see the running text instead of the splash. But changing in grub "quiet splash" to "text" went bad: the system bootet till it stopped as terminal. The whole graphic desktop didn't show up anymore. Also gedit was not possible to start as it has a graphic ui. I had to boot again and choose in the grub menu "recovery mode". Then it was possible to start in a low resolution at least. I could change grub into "quiet splash" again and now I have my former situation again It is almost a panic situation for me if the graphic does't apear anymore. Even via terminal you cannot start programs anymore with have graphic user interfaces. So be carefull changing your grub!!!

share|improve this answer
    
I'm sorry about this. I fixed my comment..."text" puts you into the command line, just "" (empty option) works, and yes, I tested that myself :-). Hopefully two helpful comments: 1) Use nano (console-based editor) if you ever get stuck without the GUI 2) if you get put into a console login, try the command startx and see if it starts up X windows (in this case, it would have done that). –  Chan-Ho Suh Apr 11 '12 at 23:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.