Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu 11.10 64 bit client as Dom0 and Xen. I am having problems getting java up and running. Java itself seems to work fine, however I get strange errors, for example when I start javaws. I tried different versions and always get the same errors.

I tried openjdk 1.6 and 1.7 as well as sunjava6 and 7. I alway get an error in the same lib

All other applications are working fine, so it seems is working fine.

Any hints what could be wrong?

Ubuntu01:~$ javaws

# A fatal error has been detected by the Java Runtime Environment:
#  SIGILL (0x4) at pc=0x00007f4e74c5ad10, pid=7974, tid=139974945277696
# JRE version: 6.0_23-b23
# Java VM: OpenJDK 64-Bit Server VM (20.0-b11 mixed mode linux-amd64 compressedoops)
# Derivative: IcedTea6 1.11pre
# Distribution: Ubuntu 11.10, package 6b23~pre11-0ubuntu1.11.10.2
# Problematic frame:
# C  []  _dl_make_stack_executable+0x2b70
# An error report file with more information is saved as:
# /home/r/hs_err_pid7974.log
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
share|improve this question
up vote 0 down vote accepted

OK, after several tries I could fix the issue myself. What worked for me was to uninstall all openjava6 and dependencies via dpkg. That left me without javaws and the plugins. So I installed sunjava7 64 Bit as described here

Now everything is working fine for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.