Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 10.04, Lucid Lynx, and I'm trying to add some fonts for use with Libre Office. In particular, I've placed a GillSans.ttc font file into /usr/share/fonts/truetype by copying it there with:

sudo cp GillSans.ttc /usr/share/fonts/truetype

and then attempting to "install" it by updating the font cache:

sudo fc-cache -fv

That appears to complete successfully, however, the font never seems to be available to either Libre Office, nor fontmatrix.

In addition, I tried adding the font to my .fonts directory, thinking that I was somehow seeing a cache of just user supplied fonts, but that isn't the case. The file is a .ttc file, is there some other tools I need to use to extract each font from the .ttc, or is there something else I must do to use a .ttc? Nothing appears to have any issue with the file, but it could be silently failing to do anything. I've looked for the answer in other places, but the only time that a similar question was asked, it did not appear to be answered, so I figured I would ask the question differently and see if anyone else might be able to clue me in on how to use a .ttc font file, if that is possible.

A related question, are there any tools to see what font families/font names are contained within a .ttc font file?

-- Edit -- Wanted to add one interesting thing: fontmatrix will see the font IF I copy it to ~/.fonts AND if I rename it GillSans.ttf. However, Libre Office still does not see the font as installed. I'm at the "WTF?" point, and am about to resort to filing some kind of bug... But I don't know if I should file one against Libre Office, Ubuntu, or both.

share|improve this question
    
Did you try double-clicking on the ttc file and clicking on Install? –  SirCharlo Apr 10 '12 at 20:00
    
I presume you mean to bring up the gnome-font-viewer? Yes, I did try that. Didn't seem to do anything. At least not as far as I could determine. Libre Office still doesn't think the font is installed. And neither does font matrix, for that matter. Although doing it a second time "fails" (presumably because the font has been installed at this point). So, as far as the gnome-font-viewer, it believes the font is installed, in that respect. But nothing else seems to see that it is installed. –  roboknight Apr 10 '12 at 20:06
    
It would appear that the "install" in gnome-font-viewer just copies the font to ~/.fonts, which I have already done by hand. –  roboknight Apr 10 '12 at 20:13

1 Answer 1

Got your GillSans.TTF right here (if the link is broken, it's easy as pie to search for). I recommend using the TTF, the most mainstream typeface format.

share|improve this answer
    
Not the same. Those fonts I actually DO have installed. –  roboknight Apr 10 '12 at 20:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.