Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have downloaded MATLAB R2012a for Unix platform and i want to install it on my ubuntu 11.10. To install i try this command:


and it says:

install: missing file operand

According to it's manual i must give it an input file, So i create an input file like this to install in 'Stand Alone' mode:







Acctually i'm not sure in "activationPropertiesFile" field what file is required, so i supposed it requires license file. I saved this file as txt format in the same directory which installation files are.

Then i tried this command:

install -inputFile my_input_file.txt

and it gets this error:

install: invalid option -- 'i'

I know there is some helps in other websites and also some questions here about this topic, but i can't figure out what's the problem, Please help me, i'm a real noob on linux .

Thank you guys


in properties of the install file i checked the item "Allow executing file as Program", now it's like this: install properties

after that i can run install file by clicking on it or by typing ./install in terminal. but in both ways i get this:

Preparing installation files ...
Installing ...
eval: 1: /tmp/mathworks_xxxx/sys/java/jre/glnx86/jre/bin/java: Permission denied

in third line xxxx is a random number every time like 6370 or 5310 ... . why i have not permission? what should i do?


using Mahesh help i tried these commands:

sudo chmod +x ./install
sudo ./install -v

the result is:

Preparing installation files ...
->  DVD                 = /home/mehdi/qBT_dir/Matlab_Unix_2012a/ml2012au
->  ARCH                = glnx86
->  DISPLAY             = :0.0
->  TESTONLY            = 0
->  JRE_LOC             = /tmp/mathworks_6114/sys/java/jre/glnx86/jre
->  LD_LIBRARY_PATH     = /tmp/mathworks_6114/bin/glnx86

Command to run:
/tmp/mathworks_6114/sys/java/jre/glnx86/jre/bin/java  -splash:"/home/mehdi/qBT_dir/Matlab_Unix_2012a/ml2012au/java/splash.png" -Djava.ext.dirs=/tmp/mathworks_6114/sys/java/jre/glnx86/jre/lib/ext:/tmp/mathworks_6114/java/jar:/tmp/mathworks_6114/java/jarext:/tmp/mathworks_6114/java/jarext/axis2/:/tmp/mathworks_6114/java/jarext/guice/:/tmp/mathworks_6114/java/jarext/webservices/ com/mathworks/professionalinstaller/Launcher -root "/home/mehdi/qBT_dir/Matlab_Unix_2012a/ml2012au" -tmpdir "/tmp/mathworks_6114" 

Installing ...
eval: 1: /tmp/mathworks_6114/sys/java/jre/glnx86/jre/bin/java: Permission denied


Last thing to do is go into /matlab-install-files/sys/java/jre/glnx86/jre/bin/java and :

sudo chmod +x ./java

and then go back to installation files directory and run install by:



sudo ./install

and it will work :-)

Thank you all specially "Mahesh" and "John"

share|improve this question
what does install --help returns ? – Web-E Apr 10 '12 at 18:51
A rare case when the question itself contains more helpful information than its answers :) – Rafał Cieślak May 14 '13 at 21:42
up vote 11 down vote accepted

Something's wrong here. I've installed Matlab R2012a, and the install file does not require any input file.

This should work.

Command line way.

  • Open Terminal
  • cd into Matlab directory ( which has the install file and is shown in your screenshot)
  • sudo chmod +x ./install
  • sudo ./install
  • This will open a window, from where you will be able to proceed yourself.

GUI way:

  • type alt+F2. this opens the run dialog
  • type gksudo nautilus and hit enter
  • open the Matlab directory (as shown in your screenshot)
  • check if install file has execute permissions (as in your screenshot)
  • Double click install. You will get a window asking you wether to display or run.
  • Click on Run
  • you should be able to find your way from here. this opens a window with necessary instructions.

as you see, The Command line way is easier and safer.. ;)

This is guaranteed to work. And just so you know, when you executed install, as described in your question, /usr/bin/install must have got executed. It is probably the one that complained of a missing file operand.

share|improve this answer
thank you but i keep getting the same error, (permission denied). – Mehdi Apr 11 '12 at 12:28
Sorry to hear that! Can you update your question with any errors/messages displayed when trying the command-line way by running sudo ./install -v after cd-ing into the matlab directory? – Mahesh Apr 11 '12 at 13:20

For the error:

eval: 1: /tmp/mathworks_11425/sys/java/jre/glnxa64/jre/bin/java: Permission denied

You have to give permissions for the java to run (credits to )

After proceeding the steps by Mahesh, go to the folder

cd sys/java/jre/glnxa64/jre/bin/ (the folder that appears in your error message)

and then

chmod +x java

Ready to go. Go back to where your install file is and type

sudo sh install

The setup will (hopefully) launch.

share|improve this answer
yes it worked, installation goes to 100%, now the problem is how can i launch it ? – Mehdi Apr 12 '12 at 13:09
you can find matlab in dash (if using Unity UI). If you cant find it there, Alt+F2 to get run dialog, and type matlab and hit enter. That should work. – Mahesh Apr 12 '12 at 13:52

I don't exactly remember how I installed Matlab (R2011a), but I believe it has a wizard you can follow. That way you can login with your mathworks credentials. iirc it is important that the folder /usr/local/MATLAB/ is writable before the installer begins.

Maybe just run install from nautilus?

share|improve this answer
I check the path /usr/local/. neither this is writable nor lots of other folders although i am admin(i think!). what should i do? – Mehdi Apr 11 '12 at 7:38

It is possible that you have more problems once you complete the install process using Mahesh's comment (chmod a+x on the folder).

So, I recommend to install the matlab-support package, which will set-up the missing dependencies, paths and scripts, and also will install a shortcut (x.desktop).

share|improve this answer

protected by Community Jul 20 '12 at 8:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.