Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I never had any problem with display. This morning Ubuntu gave me an option to install drivers for Wireless Card and Nvidia drivers for display. There were two options for wireless driver and two options for NVidia display.. For NVidia driver one option was marked as Recommended (I remember installing this when I installled Ubuntu), so today along with two Wireless Drivers (Broadcom) drivers, I installed the other NVidia driver as well. After restarting I am seeing this lag which is quite irritating. Is there anyway to rollback to previous configuration like windows?

share|improve this question
    
I take it you mean you picked the recommended driver from Jocky, the additional drivers app. –  Adam Nov 8 '10 at 13:27
    
Can you load the app from System->Administration->Additional Drivers and provide details of what it says. –  Adam Nov 8 '10 at 13:28
    
Hi Adam, I dont have access to machine right now, but I will do so as soon as a I can. –  t3ch Nov 8 '10 at 14:55

2 Answers 2

up vote 1 down vote accepted

Sounds like you installed another driver for your graphics card without reason, and possibly an old version, like the nv driver.

Open jockey (system>administration>additional drivers), and disable the extra nvidia driver (ensure you have the recommended one enabled still). You only need 1 driver.

share|improve this answer
    
Thanks Roland, How to get to Jokey? –  t3ch Nov 8 '10 at 14:56
    
sorry, updated my answer (jockey, not jokey oops!) and menu entry) –  RolandiXor Nov 8 '10 at 15:18

I don't know if this will be any help, and I'm far from an Ubuntu expert, but I was having a similar problem myself. After installing the recommended "Additional Driver" for the Nvidia card on my Pavilion TX2000, I experienced terrible lag or choppiness when scrolling in a browser,switching desktops, and basically anything that used the window manager. I tried using the install provided by NVidia, but Gnome wouldn't even load after I did that, so I went back to the recommended driver. The attempted NVidia install added a "NVidia X Server Settings" option to the System->Administration menu. I loaded this, and noted that, in the "X Server Display Configuration" section, "Resolution" was set to "Auto." I changed this to 1280x800 (the same value chosen by the "Auto" setting, by the way,) and then set the refresh rate from "Auto" to "60 Hz." After applying that setting, the issue seems to be resolved. I don't know if this will be applicable to anyone else's system, but I thought it was worth putting out there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.