Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using KDE (with Kwin) on two screens. Often when I run a new application the new window shows on the second screen eventhough the mouse as well as the active window is on the main screen. How can I instruct KDE to always open new windows on the main screen?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

In the "windows behaviour" settings, you have to enable "Active screen follows mouse pointer". (approximate translation from French but I'm sure you'll find it).

This way, by default, windows will open on the current screen. (except some rare specific apps like VLC which use the last used screen).

share|improve this answer

Try System Settings - Display and Monitor - Multiple Monitors.

The setting Show Unmanaged Windows on allows you to select a display or use the display the mouse pointer is on.

I had this problem but only when I first started a session, anything I ran would always initially open on the second screen (which is a TV and usually turned off)

If you're having the same issue as me, I only got around it by creating a rule for the browser to save its position (Right click on title bar, advanced - special window settings - size & position, Check "Position", select "Remember")

Now when I log in if I open the browser first, it still opens on the second screen but the rule overrides whichever insane hidden setting is taking effect and forces it back to the first desktop, subsequent windows then open on the first desktop as well.

share|improve this answer
    
There is no such thing as "multiple monitors" in Kubuntu 12.10. This drives me crazy as applications pop on the monitor with the mouse focus and is completely unpredictable. Any ideas? –  VitoshKa Nov 21 '12 at 12:18
    
@VitoshKa: yes in 12.10 they seem to have merged Multiple Monitors into Size & Orientation, I can't see the Show Unmanaged Windows on option anymore. There is a Primary output drop list, unfortunately the Kubuntu 12.10 machine I have here doesn't have a second monitor at the moment so I can't test it. –  Ozone Nov 27 '12 at 3:03

System Settings -> Window Behavior -> Window Behavior -> Active screen follows mouse:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.